mrp_repair: missing invalidation on fees

Bug #1281687 reported by Alexis de Lattre on 2014-02-18
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Medium
Unassigned
OpenERP Community Backports (Addons)
Status tracked in 7.0
7.0
High
Alexandre Fayolle - camptocamp

Bug Description

Here is the scenario to reproduce the bug :

1) connect to runbot (v7 or trunk)

2) Go to "Manufacturing > repair orders" and edit "RMA00004" (present in demo data ; should be in "Quotation state"). The total amount is 100.

3) In the invoicing tab, add a new fee line :
Product : Assembly Service Cost
Quantity : 1
Price : 12
To invoice : should be set to "yes" by default

In the "Operations" tab, the total amount is still 100 ; it should be 112 !

The cause of the bug is pretty obvious : the fields "amount_untaxed", "amount_tax" and "amount_total" are STORED function fields, but the invalidation function on mrp.repair.fee is missing !

The attached patch fixes the issue : it adds the missing invalidation function on the fields "amount_untaxed", "amount_tax" and "amount_total" and it also simplify the invalidation function of mrp.repair.line.

Related branches

Alexis de Lattre (alexis-via) wrote :
Changed in openobject-addons:
status: New → Confirmed
Changed in openobject-addons:
status: Confirmed → Fix Committed

Hello,

Thanks for the report and patch, we have merged it into 7.0

revno: 9881 [merge]
revision-id: <email address hidden>

Changed in openobject-addons:
status: Fix Committed → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers