account_payment : cannot pay a customer refund

Bug #1275478 reported by Alexis de Lattre on 2014-02-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
New
Undecided
Unassigned

Bug Description

Here is the scenario to reproduce the bug :

1) Connect to the runbot of OpenERP version 7.0

2) Create a new Customer Refund :
Partner : Vauxoo
Add 1 refund line with product "HDD SH1"

3) Validate the Customer Refund

4) Create a new Payment Order
Payment Mode : "Direct Payment"

5) On the new Payment Order, click on the button "Select Invoices to Pay"
Click on "Search" then "Add"
=> It doesn't propose to select the Customer Refund we just created for Vauxoo.

This is a bug : we need to be able to pay a customer refund.

The attached patch fixes the bug.

Related branches

Alexis de Lattre (alexis-via) wrote :
Stéphane Bidoul (Acsone) (sbi) wrote :

@Alexis, do you plan to propose this as a pull request to odoo?

Alexis de Lattre (alexis-via) wrote :

@sbi

I don't plan to do a pull request for this fix. Please do so if you wish.

Stéphane Bidoul (Acsone) (sbi) wrote :

@Alexis,

In any case, amount_to_pay is go in v8 core... apparently there was an attempt to replace it by amount_residual, but that one is not searchable so amount_to_pay has become credit > 0...

https://github.com/odoo/odoo/commit/700d456cb

So your workaround in banking addons is here to stay I guess.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers