Opening entries on foreign currency accounts are computing a wrong value

Bug #1257288 reported by Matthieu Dietrich @ camptocamp on 2013-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Medium
OpenERP Publisher's Warranty Team

Bug Description

If you create opening entries for a past fiscal year (FY2012) but have entries with a multicurrency account in FY2011, the opening entry for FY2013 will sum all move lines from 2012 for system currency (as wanted), and all move lines until 2013-01-01 for account currency (not wanted).

This means you get a much larger value in account currency than in system currency.

The issue is in the method data_save() in addons/account/wizard/account_fiscalyear_close.py; the domain for the lines uses all fiscal years before the "new" one, not just one. I'll add a branch with a fix (using the method "foreign_balance", which is correct).

Related branches

Changed in openobject-addons:
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)
tags: added: maintenance
Revision history for this message
Martin Trigaux (OpenERP) (mat-openerp) wrote :

Hello Matthieu,

Thanks for the report, this was indeed an issue.
I have merged this in 7.0

revno: 9756 [merge]
revision-id: <email address hidden>

Regards

Changed in openobject-addons:
status: New → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers