Inversed invoice_control value on pickings with a chained location setup

Bug #1208456 reported by Romain Deheele - Camptocamp on 2013-08-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Committed
Medium
OpenERP Publisher's Warranty Team
OpenERP Community Backports (Addons)
Status tracked in 7.0
7.0
Medium
Romain Deheele - Camptocamp

Bug Description

Hello,

This problem has been already pointed here : https://bugs.launchpad.net/openobject-addons/+bug/1088412

The bug report has pointed two different problems but the next answers and the fix are only concentrated on the first, it seems to me clearer to create this new bug report to fix the second problem.

Remember..when we configure a chained location :
     - OUT picking "Invoice control" is set to "Not Applicable"
     - INT picking "Invoice control" is set to "To be invoiced"
It seems more logical that should be the opposite.

Tested on trunk - addons rev 9346

Steps to reproduce the bug:
---------------------------
- Create a new db with demo data
- Install module:
  - sale
  - stock
- Go to Warehouse -> Configuration -> Location, select Output location
 - Edit chained location customer: Set "Chaining type" to "Manual operation"
- Confirm a sale order with Create Invoice on delivery order.

Two pickings are created:
     - OUT picking "Invoice control" is set to "Not Applicable"
     - INT picking "Invoice control" is set to "To be invoiced"

Romain

Related branches

Amit Parik (amit-parik) on 2013-08-06
Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 2 (openerp-dev-addons2)
importance: Undecided → Medium
status: New → Confirmed
tags: added: warehouse
Changed in openobject-addons:
assignee: OpenERP R&D Addons Team 2 (openerp-dev-addons2) → OpenERP Publisher's Warranty Team (openerp-opw)
tags: added: maintenance
Changed in openobject-addons:
status: Confirmed → In Progress

Hi Romin,

I have just committed fix in my branch on revision 9350,
lp:~openerp-dev/openobject-addons/7.0-opw-596283-rha
Revision ID: <email address hidden>

Could you please test the fix and confirm?
Thanks for reporting,
Rifakat

Changed in openobject-addons:
status: In Progress → Fix Committed

I think the same problem is also faced in 6.0 too.

Hi Rifakat,

Your fix resolves the problem.
Thanks,

Romain

Changed in ocb-addons:
status: New → In Progress
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers