[Trunk/7.0] Outlook Pluging - Attachments are pushed but not the E-Mail

Bug #1161295 reported by Michael Karrer on 2013-03-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Triaged
Low
OpenERP R&D Addons Team 1

Bug Description

If we push an E-Mail from the latest Outlook Plugin x64 for Outlook 2010 x64 the Attachments are stored to the Objects but not the the E-Mail itself !

Server 7.0 Rev.: 4910
Addons 7.0 Rev.: 8950

We even had different results when E-Mails are Pushed to different Objects:

Case A)
Push an E-Mail with an attachment to a Note

Result:
Attachments are Pushed
A New Message is under The Note BUT with the "Subject" only - so no Text from the E-Mail is Pushed

Case B)
Push an E-Mail with an attachment to a Partner

Result:
Attachments are Pushed
NO new message at all below the Partner

Amit Parik (amit-parik) wrote :

Hello Michael,

This problem is occurs due to on the push mail "res_id" and "model" fields are blank (which is due the code in overidden message_post(...)) and "partner_ids" contains that particular partner name. Pushing an email works with other objects(like, sales team, product etc..)

Currently this is an intensional behavior not the bug, The idea behind this override is: when I send an email to a partner (using the mailgateway, this usually means I used the partner's alias), I begin a private discussion with him, I do not post on its partner profile.

So If you push an email on a partner's profile (if type == 'email'), it will be changed into a private discussion between the partner and you (no model, no res_id, but partner.id will be in the recipients of the mail.message).

If push a message on a partner's profile you will have to set the type as 'comment' (and maybe subtype ref('mail.mt_comment')), or propose a small modification in mail/res_partner.py using a context key 'profile_post' that avoid triggering the override of model and res_id ... #Discussion by Tde.

For now I am setting this as a "Triaged" and assign this to respective team and core team will take the decision about this.

@Thibault: Would you please look into this and take the appropriate decision on it.

Thank you!

Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 1 (openerp-dev-addons1)
importance: Undecided → Low
status: New → Triaged
summary: - [7.0] Outlook Pluging - Attachments are pushed but not the E-Mail
+ [Trunk/7.0] Outlook Pluging - Attachments are pushed but not the E-Mail

Is there any news about this problem? as it is now, in my opinion, the plugin is virtually useless .
Thanks
dj

Hello,

Here's a branch for V7 that should solve this issue, lp:~openerp-dev/openobject-addons/7.0-opw-593592-rgo

Thanks.

Confirm it works!
suggest you double-check with somebody else and propose for merging.
dj

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers