[trunk/7.0]Lost pages category in knowledge

Bug #1150809 reported by Gilles Lehoux on 2013-03-07
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Status tracked in Trunk
7.0
Fix Committed
Medium
OpenERP Publisher's Warranty Team
Trunk
Fix Committed
Medium
OpenERP R&D Addons Team 1

Bug Description

Summary: Create a page category on the fly but it doesn't show up in the list of categories and is not available when creating subsequent pages.

7.0-20130224-002108

Reproduce

Install Knowledge and document management
Enable : Settings/Knowledge/Static pages
Go to Knowledge/Pages
Click Create
Enter a page name
Enter a category name (a new category), ex "Mycat"
Click "Create MyCat"
Click Save
Go back to the list of pages.
The page is listed and "Mycat" appears in the Category column.
Go to Knowledge/Categories
The category "Mycat" is not there. It should be there.
Go to Knowledge/Pages
Click Create
Click the Category drop down menu
Category Mycat is not in that menu. It should be there.
Go to Knowledge/Categories
Create a category, ex. "Mycat2"
Go to Knowledge/Pages
Click Create
Click the Category drop down menu
Category Mycat2 is in that menu. Ok.

Related branches

Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 1 (openerp-dev-addons1)
importance: Undecided → Medium
status: New → Confirmed
summary: - Lost pages category in knowledge
+ [trunk/7.0]Lost pages category in knowledge
Changed in openobject-addons:
status: Confirmed → In Progress

Hello,

  It has been fix commited in https://code.launchpad.net/~openerp-dev/openobject-addons/trunk-bug-1150809-Dharmraj branch.
  Revision No: 8602
  Revision ID: <email address hidden>

  It will be available soon in trunk.

Thanks,
Dharmraj.

Changed in openobject-addons:
status: In Progress → Fix Committed
tags: added: maintenance
Nhomar - Vauxoo (nhomar) wrote :

Hello Dharmraj.

Your solution is totally incorrect, see the MP and my bug #1185267 with your solution you are forcing all default as category, please expend 10 minutes in think correctly this kkind of very simple solution it took to me 10 minutes solve it and 30 minutes document it, please read my comments on the bug mentiones.

Hi Nhomar,

Thanks for your contribution.

The fix from your branch, lp:~vauxoo/openobject-addons/7.0-document_page_category_context, is working fine. It will soon be reviewed by our experts and then be merged with main stable V7 branch.

I will update you once this is done.

Regards.

Denis Karataev (dskarataev) wrote :

Hi, why this fix isn't in stable 7.0 branch yet? Please merge it to 7.0, I faced with same problem and I need it in 7.0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments