[Trunk/7.0] document webdav : 500 error on connection

Bug #1104559 reported by Ferdinand
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Confirmed
Medium
OpenERP R&D Addons Team 1
OpenERP Community Backports (Addons)
Status tracked in 7.0
7.0
Fix Released
Medium
Holger Brunn (Therp)

Bug Description

cadaver http://localhost:8069/webdav/se_20130124_2246
Authentication required for OpenERP User on server `localhost':
Username: ferdinand
Password:
Could not open collection:
500 Internal error
dav:/webdav/se_20130124_2246/

openerp.service.http_server: Found user="ferdinand", passwd="***" for db="se_20130124_2246"

BTW it seems mandatory to add the DB-name. this should go into the module description

Tags: 7.0

Related branches

Revision history for this message
Ferdinand (office-chricar) wrote :

 it is necessary to install
http://code.google.com/p/pywebdav/

this should be mentioned somewhere not only in the code

summary: - 7.0 document webdav : error connecting
+ [Trunk/7.0] document webdav : Need to add module description
Changed in openobject-addons:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → OpenERP R&D Addons Team 1 (openerp-dev-addons1)
Revision history for this message
Nicholas linn (nicklinn-6) wrote : Re: [Trunk/7.0] document webdav : Need to add module description
Download full text (5.3 KiB)

Having same issue. Here are the log files:
2013-03-21 20:52:42,387 31482 INFO ? openerp.service.http_server: Found user="admin", passwd="***" for db="unidem"
2013-03-21 20:52:42,464 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get length: http://192.168.0.23:8069/unidem/Documents
2013-03-21 20:52:42,475 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get contenttype: http://192.168.0.23:8069/unidem/Documents
2013-03-21 20:52:42,483 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get RT: http://192.168.0.23:8069/unidem/Documents
2013-03-21 20:52:42,488 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get etag: http://192.168.0.23:8069/unidem/Documents
2013-03-21 20:52:42,501 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get children: http://192.168.0.23:8069/unidem/Documents
2013-03-21 20:52:42,506 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: children for: Documents
2013-03-21 20:52:42,519 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: child: Admin Folder
2013-03-21 20:52:42,519 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: child: Partners
2013-03-21 20:52:42,519 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: child: Personal Folders
2013-03-21 20:52:42,520 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: child: Products
2013-03-21 20:52:42,520 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: child: Projects
2013-03-21 20:52:42,520 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: child: Sales Order
2013-03-21 20:52:42,534 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get length: http://192.168.0.23:8069/unidem/Documents/Admin Folder
2013-03-21 20:52:42,549 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get contenttype: http://192.168.0.23:8069/unidem/Documents/Admin Folder
2013-03-21 20:52:42,564 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get RT: http://192.168.0.23:8069/unidem/Documents/Admin Folder
2013-03-21 20:52:42,577 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get etag: http://192.168.0.23:8069/unidem/Documents/Admin Folder
2013-03-21 20:52:42,616 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get length: http://192.168.0.23:8069/unidem/Documents/Partners
2013-03-21 20:52:42,626 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get contenttype: http://192.168.0.23:8069/unidem/Documents/Partners
2013-03-21 20:52:42,636 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get RT: http://192.168.0.23:8069/unidem/Documents/Partners
2013-03-21 20:52:42,646 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get etag: http://192.168.0.23:8069/unidem/Documents/Partners
2013-03-21 20:52:42,677 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get length: http://192.168.0.23:8069/unidem/Documents/Personal Folders
2013-03-21 20:52:42,686 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get contenttype: http://192.168.0.23:8069/unidem/Documents/Personal Folders
2013-03-21 20:52:42,696 31482 DEBUG ? openerp.addons.document_webdav.webdav_server: get RT: http://192.168.0.23:8069/unide...

Read more...

summary: - [Trunk/7.0] document webdav : Need to add module description
+ [Trunk/7.0] document webdav : 500 error on connection
tags: added: 7.0
Changed in openobject-addons:
importance: Low → Medium
Revision history for this message
Yusuf Hasanmiyan (yusuf-hasanmiyan) wrote :

Still not working for me after install PyWebDav; I still get error 500

Revision history for this message
hwinkel (hw-travelping) wrote :

We have the same problem, even after installing pywebdav the 500 remains

Revision history for this message
ROGER (py-roger) wrote :

I'd had the same problem.
This bug seems provided from pywebdav library. I reproduce it with pywebdav 0.9.4. But with 0.9.8, this works !
You can download pywebdav 0.9.8 here : http://code.google.com/p/pywebdav/downloads/detail?name=PyWebDAV-0.9.8.tar.gz

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

More easy just install with pip.

sudo pip install pywebdav --upgrade

the correct version is available already for ubuntu.

Revision history for this message
Michael Karrer (michaelkarrer81) wrote :

After updating pywebdav to 9.8 and merging the branch i gett:

 bhctest werkzeug: 127.0.0.1 - - [12/Nov/2013 12:50:11] "HEAD /webdav/bhctest/ HTTP/1.0" 409 -

Any clues?

Revision history for this message
Michael Karrer (michaelkarrer81) wrote :

For me this is not fixed all i geht is a 409 error message - i did access the server directly so with no web server in between .

Revision history for this message
Michael Karrer (michaelkarrer81) wrote :

I have to confirm that this bug is definitely not fixed for me - always 409 error messages - even on fresh installation without web server (based on 7.0 line of server add ons and web)

Revision history for this message
Alexandre Fayolle - camptocamp (alexandre-fayolle-c2c) wrote :
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers