"Allow using different units of measures" setting is a product feature, but defined in the "sale" module which may not be installed

Bug #1098327 reported by Phil Frost on 2013-01-10

This bug report was converted into a question: question #219217: "Allow using different units of measures" setting is a product feature, but defined in the "sale" module which may not be installed.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Confirmed
Wishlist
OpenERP R&D Addons Team 2

Bug Description

The product module defines the group product.group_uom, or "Manage Multiple Units of Measure". I can enable technical features, then assign this under the access rights for each user, but this is tedious.

The solution seems to be enabling the "Allow using different units of measures" setting under Settings -> Sales. However, this is defined in the "sale" module.

If I install the accounting application, the product module will also be installed, and I will have products, and I might want to have different UoMs on my invoices. But, "Allow using different units of measures" won't be available to me, because the "sale" module isn't installed.

I think that setting should be moved to the product module, so it's always available in any configuration that has products.

Amit Parik (amit-parik) wrote :

Hello Phil,

I have checked on trunk, Settings >Configuration> Sales not visible untlil the sale module is not installed.

So I think there is not an issue, would you please try with latest trunk and let us know.

Thank you!

Changed in openobject-addons:
status: New → Incomplete

On 01/11/2013 01:45 AM, Amit Parik (OpenERP) wrote:
> I have checked on trunk, Settings >Configuration> Sales not visible
> untlil the sale module is not installed.
>
> So I think there is not an issue, would you please try with latest trunk
> and let us know.

That *is* the issue. If I am using OpenERP for just accounting, I have
products, and the products have units of measurement, and I might want
to manage those. In my particular case, we are a service company, and
some services are priced by the day. But, without this setting enabled,
all services are billed by the hour, and there's no way to change it.

But the problem is that without the sale module installed, I can't
enable this setting, configuration -> sales -> "Allow using different
units of measures", precisely because there is no configuration ->
sales, because the sale module isn't installed, because I'm not doing
sale orders in OpenERP, but just accounting. Make sense?

Amit Parik (amit-parik) wrote :

Hi Phil,

Thanks for your detailed explanation.

I want to show you one more thing, you can see the "Manage Multiple Units of Measure" group (privileges ).
You can assign your user to this group and then you can change the unit of measure on product as well as invoice line too.

I think this will helps you.

Note: "Manage Multiple Units of Measure" group will be visible when you assign first "Technical feature" group into your user.

Thank you!

Changed in openobject-addons:
status: Incomplete → Invalid
Phil Frost (bitglue) wrote :

Did you read my original bug report?

> The product module defines the group product.group_uom, or "Manage Multiple Units of Measure". I can enable technical features, then assign this under the access rights for each user, but this is tedious.

I'm well aware of that setting. This is a usability bug, in that if I don't have the sale module installed, I have to go through to each user and check that box. This is just plain silly, since the sale module has a solution. Why is a solution to a problem with the product module in the sale module?

Changed in openobject-addons:
status: Invalid → New
Numérigraphe (numerigraphe) wrote :

Maybe you should explain a bit more of what "want to have different UoMs on my invoices" means.

If it means checking a box will add a second UoM to invoices, then it's just not the same feature as in sales.
Secondary UoMs as they are implemented are used mostly in sales, and could possibly be used in stock and I think that's it. Invoices still have a single UoM.

Lionel.

Changed in openobject-addons:
status: New → Incomplete
Phil Frost (bitglue) wrote :

Here's a use case, as a user story:

As a service company, I'd like to invoice my services in units other
than hours.

In OpenERP 6, I could change the primary UoM for my services to anything
I'd like. We have some services that are sold by the day. We have some
that are a fixed rate, independent of time, and we sell them by the unit.

In OpenERP 7, the only way to accomplish this is to enable multiple
units of measure. The only way to do this with just the accounting
module installed is to enable technical features, then click through
every single user and grant them the access right. It works, but it's
tedious and not very usable.

There's a solution to this tedium, but it's only available if the sale
module is installed: settings -> sales -> Allow using different units of
measures. But this isn't actually about the sale module, it's about the
product module. I'm proposing that that setting be made available by the
product module, and not the sale module.

Amit Parik (amit-parik) on 2013-01-16
Changed in openobject-addons:
status: Incomplete → Confirmed
importance: Undecided → Wishlist
assignee: nobody → OpenERP R&D Addons Team 2 (openerp-dev-addons2)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers