[Trunk] It should be impossible to use different charts of account accounts in the same move

Bug #1089534 reported by Frederic Clementi - Camptocamp
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Confirmed
Medium
OpenERP R&D Addons Team 3

Bug Description

Hello,

By mistake I have installed the cutoms Chart of account + an other one.

I noticed that it is possible to post a journal entry (=move) with account from 2 different Chart of account.
This should be forbiden by the system.

We added a set of constraint in this v7, this one should be added

Thanks

Frederic
Camptocamp

Tags: invoicing
summary: - [Trunk] It should be impossible to use different cahrt of account
- accounts in a same move
+ [Trunk] It should be impossible to use different charts of account
+ accounts in the same move
Revision history for this message
Amit Parik (amit-parik) wrote :

Hello Frederic, Alexandre,

I have traced this issue and see that on 6.1 we have a constraint that we are not able to install the more then on chart of account for particular company.

But on version 7 and more we have removed this constraint, that's why we are able to install more then one chart of account for one company because of these I can see the same problem, I am able to create/post journal entry for different chart of account.

Currently I am not sure this kind of behavior either its problem or its fine( But I also think that this should not be possible we have to put the restriction on journal entry account.move).

@camp2camp: you guys please give a close look into this and suggest the better solution.

So currently I am setting this as an "Opinion", and want to take suggestion form community.

@Accounting Experts: Would you please give your some valuable time on this and share your opinion about this.

Thanks and more suggestions are welcomed!

Changed in openobject-addons:
status: New → Opinion
Revision history for this message
qdp (OpenERP) (qdp) wrote :

wtf?

Amit, let me confirm this as a bug: we should not be able to use accounts from different Charts of Accounts within the same account.move (i thought there was a check for that), which mean if the root account of all the accounts used in this move is not he same.

Moreover, i don't remember we removed the constraint restricting a company to a single COA... This should be checked as well.

Thanks

Changed in openobject-addons:
importance: Undecided → Medium
status: Opinion → Confirmed
Amit Parik (amit-parik)
Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 3 (openerp-dev-addons3)
Revision history for this message
qdp (OpenERP) (qdp) wrote :

one thing came in my mind: for consolidated COA, it may be needed to have several accounts with no parent and belonging to the same company... Or we can decide that consolidated COA must have no companies....

(this comment dosen't change anything to the bug: it must be restricted to use accounts from different COA in the same move)

Revision history for this message
Luc Maurer @ Camptocamp (lmaurer-c2c) wrote : Re: [Bug 1089534] Re: [Trunk] It should be impossible to use different charts of account accounts in the same move

Hello,

I fully agree that it is a bug => for a same entry we should not have 2 COA
structures

Regarding the comment of qdp for consolidation COA => it is not a problem
as even a Consolidation COA has is own COA structure (we will create a
consolidation root)., this one should be added

A+

Revision history for this message
qdp (OpenERP) (qdp) wrote :

Luc,

yes but to what company does the Consolidation COA's structure belong? the main company? then you must allow having several COA strcture per company... it belongs to no company? ok but then it means that you can't restrict visibility using the default multi-company rules...

that was what i meant in my previous comment.
A++

Revision history for this message
fblauer (fblauer) wrote : Re: [Openerp-expert-accounting] [Bug 1089534] Re: [Trunk] It should be impossible to use different charts of account accounts in the same move

@Eric - It doesn't make sense to me to have a chart of accounts for each
year. If you adjust the previous year, you would have to adjust the current
year also, since it would affect your retained earnings.
I am thinking that for some companies who are transitioning to IFRS, they
might want to maintain 2 chart of accounts temporarily, since they might
have to report both accounting methods during the transition. But I don't
think you should ever have an entry from one chart of accounts to the
other.

On Wed, Jan 23, 2013 at 6:51 AM, qdp (OpenERP) <email address hidden>wrote:

> Luc,
>
> yes but to what company does the Consolidation COA's structure belong?
> the main company? then you must allow having several COA strcture per
> company... it belongs to no company? ok but then it means that you can't
> restrict visibility using the default multi-company rules...
>
> that was what i meant in my previous comment.
> A++
>
> --
> You received this bug notification because you are a member of OpenERP
> Accounting Experts, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1089534
>
> Title:
> [Trunk] It should be impossible to use different charts of account
> accounts in the same move
>
> Status in OpenERP Addons (modules):
> Confirmed
>
> Bug description:
> Hello,
>
> By mistake I have installed the cutoms Chart of account + an other
> one.
>
> I noticed that it is possible to post a journal entry (=move) with
> account from 2 different Chart of account.
> This should be forbiden by the system.
>
> We added a set of constraint in this v7, this one should be added
>
> Thanks
>
> Frederic
> Camptocamp
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openobject-addons/+bug/1089534/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openerp-expert-accounting
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~openerp-expert-accounting
> More help : https://help.launchpad.net/ListHelp
>

--
Fred Blauer CA, CA.IT, CISA
http://openacct.ca
<email address hidden>
514-667-1555

Amit Parik (amit-parik)
tags: added: invoicing
Revision history for this message
Sunil Sharma(OpenERP) (sunil.sharma-openerp) wrote :

Hello,

i have tested your bug with latest revno but i am not able to reproduce it. because not able to install the more then on chart of account for particular company.

will you please check with latest code,if you still face any problem reopen issue with more information.

Thanks,
Sunil Sharma.

Changed in openobject-addons:
status: Confirmed → Fix Released
Revision history for this message
qdp (OpenERP) (qdp) wrote :

Did you try with the demo chart of account + the generic one (for example) ?

Revision history for this message
Mohammad Alhashash (alhashash) wrote :

I think it is acceptable to have multiple CoA per company, but account moves should only affect single chart.

For example, I created a separate inventory control chart. Balances of this chart are shown in main chart using consolidation accounts. Another use case is completely separate chart for control accounts to serve certain workflows without affecting the main accounts.

Also, a chart that consists of only consolidation accounts may be created to show different company view.

Revision history for this message
qdp (OpenERP) (qdp) wrote :

another example: if you have 2 companies in your system, each one with his own COA, then a user can see both COA. Hence it's important to restrict the account move creation with a constraint as explained above.

Guys, the bug report is 1 year old... so please start working on it.

Changed in openobject-addons:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers