[trunk/7.0]OE chatter in Page Print

Bug #1089217 reported by Parthiv Patel on 2012-12-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Committed
Medium
Christophe Matthieu (OpenERP)
OpenERP Community Backports (Addons)
Undecided
Unassigned

Bug Description

It's really nice to have feature of doing directly print from OpenERP Page view, (Great work by web team ) but what could lack people using this functionality is the printing of "Chatter Conversation" at the bottom.

This is also included as a part of page print, and which is slightly annoying.

Cheers,
Parthiv

Related branches

Parthiv Patel (parthiv-patel) wrote :
Fabrice (OpenERP) (fhe) wrote :

Considering the page view is a representation of a business document, I tend to agree with removing OpenChatter from the printed page. However, we have to make sure that the document history is never going to be essential on the printed document as OpenChatter can have that functionality too (not only discussions).

Daniel Reis (dreis-pt) wrote :

If it has to be an On/Off decision, then it's better "off".
But I agree with Fabrices's comment.
The perfect solution would be to have a flag on the GUI to hide /display the chatter.

Changed in openerp-web:
status: New → Fix Released

Inside the trunk branch, actually the print does not display the chatter for the invoice and sales order

Parthiv Patel (parthiv-patel) wrote :

seems like some new commits have done regression and now we are getting open chatter again in print.

Cheers,
Parthiv

Changed in openerp-web:
status: Fix Released → Confirmed
Parthiv Patel (parthiv-patel) wrote :

Tested on following :

    server (4808)
    addons (8616)
    web (3729)

Cheers,
Parthiv

Hello Parthiv,

Tested again with latest build of trunk as well as with 7.0 on runbot :

    (Build 2533)
    server (4769)
    addons (8523)
    web (3673)

But, As per the Christophe comment #4 the print did not display the chatter for the invoice and sales order. So, I has been already released in trunk.So, Would you please try with latest build ? And notify us if still have the issue.

Thank you.

Changed in openerp-web:
status: Confirmed → Fix Released
Parthiv Patel (parthiv-patel) wrote :

Hi Twinkle,

You seems to be checking wrong things, can you compare the revisions that I have provided and you have mentioned. You seems to be way to in early stage.

FYI .

Attached is the pdf print that I took along with version info.

(Build 2860)
    server (4819)
    addons (8648)
    web (3737)

Changed in openerp-web:
status: Fix Released → New
Changed in openerp-web:
status: New → Confirmed
Changed in openerp-web:
assignee: nobody → OpenERP R&D Web Team (openerp-dev-web)
importance: Undecided → Medium
summary: - OE chatter in Page Print
+ [trunk/7.0]OE chatter in Page Print

The chatter is part of the addons project, not the web framework. I re-assign.

affects: openerp-web → openobject-addons
Changed in openobject-addons:
assignee: OpenERP R&D Web Team (openerp-dev-web) → OpenERP R&D Addons Team 1 (openerp-dev-addons1)
assignee: OpenERP R&D Addons Team 1 (openerp-dev-addons1) → Christophe Matthieu (OpenERP) (chm-openerp)

Hello,

I think this patch can fix the issue of oe_chatter and oe_im in print page.

Thankz YoU.

Changed in openobject-addons:
status: Confirmed → In Progress
Changed in openobject-addons:
status: In Progress → Fix Committed
Changed in openobject-addons:
status: Fix Committed → In Progress

Hello,

  It has been fix commited in https://code.launchpad.net/~openerp-dev/openobject-addons/trunk-bug-1089217-dja
  Revision No: 9032
  Revision ID: <email address hidden>

Thanks,
dja.

Changed in openobject-addons:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers