Global taxes warning on tax analytic account

Bug #1084822 reported by tdombos on 2012-11-30
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Committed
Low
OpenERP R&D Addons Team 3
OpenERP Community Backports (Addons)
Status tracked in 7.0
7.0
Undecided
Unassigned

Bug Description

When setting an analytic account on a tax line in a supplier invoice, the following error message is given on validation:

Warning!
Global taxes defined, but they are not in invoice lines !

Only if setting the tax analytic account to the default account set in Invoice Tax Analytic Account at the tax definition screen does the invoice get properly validated.

Related branches

Amit Parik (amit-parik) wrote :

Hello Tamas,

You are doing a wrong configuration, you can't manually edit the tax line cause this it should also affect on invoice line too.

I have prepared a video and attached with this bug report, would you please check it and notify us have you still faced the problem or not..

Thanks and waiting for your reply!

Amit Parik (amit-parik) wrote :
Changed in openobject-addons:
status: New → Incomplete
tdombos (tdombos) wrote :

Yes, I understand that you can set a default analytic account to collect all taxes, this however, is an unreasonable limitation. We are an NGO that cannot reclaim VAT. Our analytic accounts reflect various donor funded projects. Most donors allow for paying VAT from grants, some don't. In the first case the tax should be accounted in the same analytic account as the main invoice line. It is only in the second case, that a catchall Invoice Tax Analytic Account is a good solution.

Btw a UI design principle: if something should not be done, the user should not be able to do it. Making the tax lines look editable invites people to actually edit them. The fields should be disabled then, if they should not be edited.

Amit Parik (amit-parik) wrote :

Hello Tamas.

This thing is already imporved on tunk 7.0 vesrion, you can not edit the tax invoice line.

So this issue doesn't affect for the latest version, and also its not a bug for 6.1 too.

That's why I am closing this issue.

Thank you!

Changed in openobject-addons:
status: Incomplete → Invalid
tdombos (tdombos) wrote :

I have just checked the trunk version in runbot, and the tax lines are still editable.

Changed in openobject-addons:
status: Invalid → New
Amit Parik (amit-parik) wrote :

Hello Tamas,

On 7.0 we had remove the "Compute Taxes", So whenever you validated the invoice then after tax line will generated.

And After validate the invoice the tax line will become readonly.

Please check the attached the video.

Thank you!

Amit Parik (amit-parik) wrote :
Changed in openobject-addons:
status: New → Invalid
Stéphane Bidoul (Acsone) (sbi) wrote :

Hello,

I've carefully read the discussion about this bug, and I believe there is a real issue here. So if you don't mind, I'll re-open it in order to discuss in more details.

Issue description: can't set analytic accounts on tax lines.

How to reproduce:
- install accounting, with l10n_be
- in configuration, enable analytic accounting
- create a supplier invoice
- create an invoice line for 1000€ with account 600000, tax VAT-IN-V82-CAR-EXC, and set an analytic account on the invoice line
- update to compute the taxes

-> notice all analytic account remain empty in the Taxes list
-> since with this tax code, 50% of the VAT is non recoverable, it goes to the base account on which we want an analytic account: the analytic account should therefore be propagated to such tax lines too

- the taxes should look like this

Tax Description | Tax Account | Analytic account | Base | Amount
VAT-IN-V82-CAR-EXC-C1 | 600000 | My Analytic Account | 1,000.00 | 105.00
VAT-IN-V82-CAR-EXC-C2 | 411059 | | 1,000.00 | 105.00
VAT-IN-V82-CAR-EXC-C3 | 600000 | My Analytic Account | 1,000.00 | 0.00

-> if I change the analytic account on taxes manually and click validate I get an error: "Global taxes defined, but they are not in invoice lines !", so I can't validate the invoice
-> if I click on (update) to recompute the taxes, the analytic accounts on taxes are lost again

I understand it is possible to set the analytic account on the tax itself, but this is not what we want to do, as it would imply the same analytic accounts for all invoices using that tax. That may be ok for tax accounts, but it is not for expense accounts.

In my opinion, there are two things to do to solve this:
A/ make the analytic account column read-only in the taxes box on invoices, to avoid confusing the user
B/ when tax lines are generated on the same financial accounts as invoice lines, the analytic accounts should be propagated from the invoice lines to the tax lines.

The rationale for B/ is as follow. In situations like the example above (car expenses in Belgium), only a part of the VAT must go to the VAT Deductible account (411059), and the rest must go to the expense account (600000). Many companies have a rule that all expense and revenue accounts must have an analytic account, and the current implementation makes it impossible to inforce this rule. The only workaround with the current implementation is to set an analytic account on the tax definition itself, but that would require to create a new tax for each analytic account, which is not feasible in practice.

Best regards,

-sbi

Changed in openobject-addons:
status: Invalid → New
Stéphane Bidoul (Acsone) (sbi) wrote :

A word regarding versions. In 6.0 and 6.1, the problem is present but less visible since the analytic account column is not present on taxes, so users discover it later when checking the analytic balance and/or discover transactions on expense accounts with missing analytic accounts.

Amit Parik (amit-parik) wrote :

Thanks Stephane,

For detailed explanation, faced the same problem. I am going to confirm this issue.

Thank you!

Amit Parik (amit-parik) on 2013-05-30
Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 3 (openerp-dev-addons3)
importance: Undecided → Low
status: New → Confirmed
Houssine (houssine-bakkali) wrote :

Thanks Stephane for your detailed explanation and merge proposal.

We are facing the same problem for our customers.

Can we expect this bug be tackled with a high priority and land on branch soon?

Do we need to report it on our support contract?

Thanks!
Houssine

Amit Parik (amit-parik) on 2013-10-21
tags: added: taxes
Changed in openobject-addons:
status: Confirmed → In Progress

Hello tdombos,

Thanks for reporting and Laetitia Gangloff (Acsone) for contributing. This bug has been resolved in
branch : https://code.launchpad.net/~openerp-dev/openobject-addons/trunk-bug-1084822-bde
with following:
Revision ID : <email address hidden>
Revision Number : 9028

Once reviewed by our experts it will be merged in addons soon.

Thanks & Regards,
Devnani Bharat R.

Changed in openobject-addons:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions