[trunk][6.1] l10n_it: wrong tax code sign for partially deductible tax

Bug #1083635 reported by Lorenzo Battistini on 2012-11-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Low
OpenERP R&D Addons Team 3

Bug Description

Steps:

 - Create new db installing Italian CoA
 - Create one supplier invoice with one line of 100 + 'Iva al 21% (credito)' and confirm
 - Tax code balance for 'IVA a credito ' is correctly -21
 - Create another invoice with one line of 100 + 'IVA al 21% detraibile al 50%' and confirm

Tax code balance for 'IVA a credito ' is -10.50 instead of -31.50.
This is because the sign of deductible component of 'IVA al 21% detraibile al 50%' is not -1

Related branches

Changed in openobject-addons:
assignee: nobody → Lorenzo Battistini - Agile BG - Domsense (elbati)
Lorenzo Battistini (elbati) wrote :

I'm attaching patch for 6.1

Lorenzo Battistini (elbati) wrote :

And here is patch for trunk

Changed in openobject-addons:
assignee: Lorenzo Battistini - Agile BG - Domsense (elbati) → nobody
Amit Parik (amit-parik) on 2012-11-30
Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 3 (openerp-dev-addons3)
importance: Undecided → Low
status: New → Confirmed
Changed in openobject-addons:
status: Confirmed → Fix Released
Lorenzo Battistini (elbati) wrote :

For 6.1, the new 22% VAT needs fixing too

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers