Multiple payment not working on POS module

Bug #1040009 reported by Michael Njoku
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Confirmed
Medium
OpenERP Community (OBSOLETE)

Bug Description

There is a bug openerp POS module. When you create two
payment methods. and split payment between the two payment methods,
for instance an order of $150, I pay $100 with payment type 1 and $50
with payment type 2. It records the full payment in only one of the
payment methods.

Revision history for this message
Amit Bhavsar (Open ERP) (amb-openerp) wrote :

Hello Michael,

I have tested your Issue with latest revision,
server : 4401
addons : 7370
web : 3036.

But I found both payment term. That's why I have attached the video. would you please check it and notify us where you have faced the problem.

Thanks and waiting for your reply!

Changed in openerp-web:
status: New → Incomplete
Revision history for this message
Michael Njoku (micochuks) wrote : Re: [Bug 1040009] Re: Multiple payment not working on POS module

The bug has been fixed in the last revision. Thanks
------Original Message------
From: Amit Bhavsar \(Open ERP\)
Sender: <email address hidden>
To: <email address hidden>
ReplyTo: Bug 1040009
Subject: [Bug 1040009] Re: Multiple payment not working on POS module
Sent: Sep 7, 2012 2:00 PM

Hello Michael,

I have tested your Issue with latest revision,
server : 4401
addons : 7370
web : 3036.

But I found both payment term. That's why I have attached the video.
would you please check it and notify us where you have faced the
problem.

Thanks and waiting for your reply!

** Attachment added: "Working fine with multiple payment"
   https://bugs.launchpad.net/openerp-web/+bug/1040009/+attachment/3298193/+files/POS_trunk.ogv

** Changed in: openerp-web
       Status: New => Incomplete

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1040009

Title:
  Multiple payment not working on POS module

Status in OpenERP Web:
  Incomplete

Bug description:
  There is a bug openerp POS module. When you create two
  payment methods. and split payment between the two payment methods,
  for instance an order of $150, I pay $100 with payment type 1 and $50
  with payment type 2. It records the full payment in only one of the
  payment methods.

To manage notifications about this bug go to:
https://bugs.launchpad.net/openerp-web/+bug/1040009/+subscriptions

Sent from my BlackBerry wireless device from MTN

Revision history for this message
Amit Parik (amit-parik) wrote :

Hello Michael,

Thanks for your reply.

Now I am closing this issues based on your comment.

Changed in openerp-web:
status: Incomplete → Invalid
Revision history for this message
Milan Tribuson (milan-infokom) wrote :

This is probably fixed in trunk/version 7, but it stil exists in version 6.1

Changed in openerp-web:
status: Invalid → New
affects: openerp-web → openobject-addons
Changed in openobject-addons:
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
achraf el ammouri (achrafelammouri) wrote :

Hello,

I confirm that the multiple payement methods in POS still not working on 6.1 even in latest revision.

Any help ?

Best regards,

Revision history for this message
achraf el ammouri (achrafelammouri) wrote :

When using multiple payments in point_of_sale 6.1 everything looks fine in POS and in print but when you go to POS backend you will see that there are no multiple payments saved and that full sum is saved on first payment method.
You can try this:
- create a POS order in Point of Sale
- go to payment and use at least 2 payment methods
- validate the receipt
- go to POS backend to saved receipt and you will see that only one payment is saved

Changed in openobject-addons:
assignee: OpenERP Publisher's Warranty Team (openerp-opw) → OpenERP Community (openerp-community)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers