OpenLP - Worship Presentation Software

Enabling VLC causes stack trace and prevents OpenLP from starting

Reported by Phill on 2012-03-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenLP
High
Andreas Preikschat

Bug Description

From: http://support.openlp.org/issues/499

Ubuntu
OpenLP 1.9.9

 File "/usr/lib/pymodules/python2.6/openlp/core/ui/media/vlc.py", line 894, in media_player_new
    p._instance = self
AttributeError: 'NoneType' object has no attribute '_instance'

 Got to the media tab, saw the VLC option and ticked it, moved it to the top of the list. Got two "oops" messages one after the other. (Tracebacks are in the attached file - same error as before I think.)

 - I hadn't deleted the config file.

After deleting that, and the files in ~/.local/share/openlp, and reinstalling, and restarting the computer (didn't work without that), openlp started with a "first use" wizard. So now it is working with the default songs etc. I haven't tried getting back our own songs, bibles, themes etc yet. I will report back after trying that.

Related branches

lp:~googol/openlp/bug-966086
Merged into lp:openlp at revision 1956
Tim Bentley: Approve on 2012-04-28
Raoul Snyman: Pending requested 2012-04-28
rimach (crichter) wrote :

I can reproduce this issue also at Windows XP with a VLC Version older than 1.1

VLC doesnt recommend usage of VLC Version 1.0.6 for ubuntu anymore.
see: http://www.videolan.org/vlc/download-ubuntu.html

May you could upgrade to a newer version of VLC to solve this issue!

I recommend to close this defect!

Jonathan Corwin (j-corwin) wrote :

Can we put an error trap around, and disable VLC if this error occurs?

Changed in openlp:
status: New → Confirmed
importance: Undecided → High
rimach (crichter) on 2012-04-10
Changed in openlp:
assignee: nobody → rimach (crichter)
Changed in openlp:
assignee: rimach (crichter) → Andreas Preikschat (googol)
milestone: none → 1.9.10
status: Confirmed → Fix Committed
Changed in openlp:
status: Fix Committed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers