OpenLP - Worship Presentation Software

Creating Mac OS X build fails without Aqua

Reported by matysek on 2012-01-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenLP
Low
matysek

Bug Description

I was trying to create a build when logged only using ssh. Creating build failed. The build fails when running applescripts:
  - applescript-adjustview-10-6.master
  - applescript-seticon-10-6.master

This is because applescripts use 'Finder' app to set icon and background on dmg. And 'Finger' is a gui app from Mac.

We should find a different way to set icon and background on dmg without Mac graphical interface.

Tags: osx Edit Tag help
matysek (mzibricky) wrote :

Btw, the functionality of scripts applescript-adjustview-10-6.master and applescript-seticon-10-6.master could be also rewritten in python using the 'Finder' module!

matysek (mzibricky) wrote :

The proper solution is one of these:
- set icon and background without 'Finder'
- add option to build script to disable icon and background in automated builds

A few other tools and scripts to set icon and background of dmg file is discussed here:

http://stackoverflow.com/questions/96882/how-do-i-create-a-nice-looking-dmg-for-mac-os-x-using-command-line-tools

Some tools discussed there:
- http://www.yoursway.com/free/#createdmg
- http://c-command.com/dropdmg/
- http://www.objectpark.org/buildDMG.html
- http://hg.adium.im/adium/file/c3da6ccb3f7f/Release
  - these scripts from adium seems to be a good base since they do not need Mac OS X gui to create dmg with icon and background

Changed in openlp:
status: New → Confirmed
importance: Undecided → Low
tags: added: osx
matysek (mzibricky) wrote :

This is already fixed. In the new build script there is option --devel that will create dmg without osx gui. However, without osx gui the dmg background is not set.

Changed in openlp:
assignee: nobody → matysek (mzibricky)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers