cannot delete a theme if it is assigned to a song.

Bug #913508 reported by John Cegalis on 2012-01-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
Medium
Tim Bentley

Bug Description

I tried to delete a theme and got an error that it cannot be deleted because it is assigned to a song. You cannot go through all your songs in your database to remove the association. These two old bugs also referred to the same problem and it was corrected.

https://bugs.launchpad.net/openlp/+bug/693202
https://bugs.launchpad.net/openlp/+bug/700089

Related branches

Tim Bentley (trb143) wrote :

Try using the search to find the theme.

Changed in openlp:
status: New → Invalid
status: Invalid → Incomplete
Jonathan Corwin (j-corwin) wrote :

Perhaps the error message could mention that? It didn't occur to me either, since I'd forgotten there was a song search by theme as I've never used it.

Meinert Jordan (m2j) wrote :

From users point of view it would be best to see a warning dialog with the option to proceed or to cancel (the most advanced version would also offer a list of associated items).

For programmers this would mean either removing the theme from all associated items or using the next level default theme as fall-back in case the the theme does not exist. I'd prefer the later solution, as it also works if users try to copy the songs.sqlite without taking the themes into account.

Changed in openlp:
status: Incomplete → Confirmed
importance: Undecided → Low
importance: Low → Wishlist
Tim Bentley (trb143) on 2015-09-13
Changed in openlp:
assignee: nobody → Tim Bentley (trb143)
status: Confirmed → In Progress
importance: Wishlist → Medium
Tim Bentley (trb143) on 2015-11-05
Changed in openlp:
milestone: none → 2.3.0
status: In Progress → Fix Committed
Tim Bentley (trb143) on 2015-12-28
Changed in openlp:
milestone: 2.3.0 → 2.3.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers