OpenLP - Worship Presentation Software

Linked audio will not play when song sent Live from a saved Service

Reported by Derek Robin Chambers on 2011-11-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
High
Raoul Snyman

Bug Description

OpenLP Version: 1.9.7
System: Dell M5010; Athlon II P360 running Windows 7 Home Premium 64-bit service pack 1,

Problem is with linked audio and occurs identically and consistently with *.mp3, *.m4a, *.wma and *.wav files irrespective of whether linked as Files or as Media. Don't believe it's a codec problem because the linked audio works perfectly:

    when send song Live from Media Manager
    when send song Live from Preview
    when add song to Service and send Live from the Service

Problem only occurs after Service is saved (not closed and reopened: just saving the Service is enough to cause it). After saving Service, audio will no longer play when the song is sent Live from that Service.

Audio will still play though:

    when send song Live from Media Manager
    when send song Live from Preview
    when add another copy of song to Service and send that copy to Live from the Service, although the copy that was already in the Service before hitting the Save button continues to fail.

Problem never prevents the little pause icon appearing in the Live section.

Other systems
Problem also occurs with Dell Inspiron I1520; Intel T7250 running Windows Vista Home Premium 32-bit service pack 2 (still OpenLP 1.9.7).

Further information
If song added to Service from Preview and the song is left in Preview, saving the Service also stops the audio working when song sent Live from Preview. Reloading song from Media Manager to Preview restores correct behaviour to Preview.

Related branches

lp:~raoul-snyman/openlp/bug-888815
Merged into lp:openlp at revision 1904
Tim Bentley: Approve on 2012-03-13
Jonathan Corwin: Approve on 2012-03-12
Changed in openlp:
milestone: none → 1.9.9
assignee: nobody → Raoul Snyman (raoul-snyman)
Changed in openlp:
status: New → Confirmed
importance: Undecided → High
Changed in openlp:
status: Confirmed → Fix Committed
Changed in openlp:
status: Fix Committed → Fix Released

One more piece of info: once the problem has been triggered by saving service, the time-remaining counter that you have (very usefully thank you) added beside the pause button in the Live panel does not change when hitting unpause to start (unsuccessfully) playing the track. Neither does it change if then hit pause (don't expect it to). Hitting unpause again though changes it to -1:59, where it remains however many times you toggle the pause button. I've tried this for 3 different songs - the time it sticks at is always -1:59.

Seems to be fixed in Jon Tibble's bzr1436 build

With regard to the nighty builds, just wanted to
flag up that bug #888815 remains unfixed in
http://openlp.org/files/OpenLP-1.9.8-bzr1910-setup.exe
but IS fixed in
http://builds.projecthq.biz/media-test-OpenLP-1.9.8-bzr1436-setup.exe
Is this right? I'm certainly happy now: 1436 solves my main problem and also runs yesterday's service without any problems so will probably be the one I stick with until 1.9.9 comes out.
Many thanks

Jonathan Corwin (j-corwin) wrote :

Yes that is right. The bzr1486 was just an experimental version to check the fix worked.
It hit trunk in revision 1912 after the nightly rebuild was done yesterday. It should therefore be included tonight.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers