Jpegs can't be used as backgrounds in MacOS

Bug #648472 reported by wezlo on 2010-09-27
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenLP
Medium
Matthias Hub
Documentation
Medium
Wesley Stout

Bug Description

I went to create a theme in 1.9.3 on my macbook and the only images that were able to be used were png's. Jpegs were greyed out, and when I toggled the selection tool to "all images" Jpegs returned an error.

Tim Bentley (trb143) wrote :

Can we have more information on the error please.
Stack trace etc.

Changed in openlp:
status: New → Incomplete
Raoul Snyman (raoul-snyman) wrote :

The correct Qt codec file needs to be found and included in the OS X build.

Changed in openlp:
status: Incomplete → Confirmed
importance: Undecided → Medium
assignee: nobody → Matthias Hub (matthiashub)
milestone: none → 1.9.4
Matthias Hub (matthiashub) wrote :

With the default build process for 1.9.4 it worked out-of-the-box on the 10.5.8 development box for me. Will test it on two other systems (clean 10.5.8 and 10.6.5).

Raoul Snyman (raoul-snyman) wrote :

Yes, this is probably because the bundled Qt in the .app can see the Qt.framework's codec.

Tim Bentley (trb143) on 2011-01-08
Changed in openlp:
milestone: 1.9.4 → 1.9.5
Matthias Hub (matthiashub) wrote :

JPEG library is already bundled with 1.9.4, need to be verified in the final build.

Matthias Hub (matthiashub) wrote :

build on 10.6 works, jpeg still doesn't work on 10.5, even though there is the libqjpeg in the imageformats directory and bundled within qt4_plugins.

Jonathan Corwin (j-corwin) wrote :

Is this something that can be fixed in 10.5? If so, how likely before next week or should we bump to 1.9.6?

Matthias Hub (matthiashub) wrote :

It is just a packaging problem (I guess), which I have some time next weekend to look into. The bad thing is that I cannot ensure that this will be fixed, because I don't know the root cause of the problem yet :-(

Changed in openlp:
milestone: 1.9.5 → 1.9.6
Aaron Rathjen (aaron-x) wrote :

I can confirm this bug in builds 1588, 1549, and 1421 on my system, which is 10.6.7.

I cannot use jpegs in either the themes or in the image plugin.

Matthias Hub (matthiashub) wrote :

Yes I finally found out the reason for that, as we are packaging a lot with the application, but only for the i386 architecture and it seems that we need to package it also for the 64bit for Snow Leopard. I will set up a development system for compiling universal binaries on a Snow Leopard system. That's the plan for Saturday :-) (I hope that you are able to enjoy JPEGs on Snow Leopard then on the next weekly build if all goes well...)

Matthias Hub (matthiashub) wrote :

Yep, that was the reason, JPEG as background images are working now on Snow Leopard, will be out for testing with the next build

Changed in openlp:
status: Confirmed → In Progress
Changed in openlp:
status: In Progress → Fix Released
wezlo (revwez) wrote :

1.9.6 build on Snow Leopard still doesn't allow for jpegs to be used...

Matthias Hub (matthiashub) wrote :

@wezlo sorry yes, currently there is only the Leopard build available, the packaging of the Snow Leopard version did not pass testing yet.. Sorry for the inconvenience. I will update this bug here after we published the final package.

Gotcha, looking forward to it!
Sent from my iPad

On Jun 26, 2011, at 11:46 AM, Matthias Hub <email address hidden> wrote:

> @wezlo sorry yes, currently there is only the Leopard build available,
> the packaging of the Snow Leopard version did not pass testing yet..
> Sorry for the inconvenience. I will update this bug here after we
> published the final package.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/648472
>
> Title:
> Jpegs can't be used as backgrounds in MacOS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openlp/+bug/648472/+subscriptions

Andreas Preikschat (googol) wrote :

Re open the bug, so that it is visible on the list again. See also http://support.openlp.org/issues/213

Changed in openlp:
milestone: 1.9.6 → none
status: Fix Released → In Progress
Andreas Preikschat (googol) wrote :

Hm... not sure if I accidenlty set the milestone to none or if it was launchpad... :-)

Changed in openlp:
milestone: none → 1.9.6
matysek (mzibricky) wrote :

This issue is caused by a bug in pyinstaller: http://www.pyinstaller.org/ticket/373

Jpeg images should work correctly with builds created by latest pyinstaller svn version.

Matthias Hub (matthiashub) wrote :

matysek, that looks very good! wezlo can you try the latest build from http://www.matthiashub.de/tmp/openlp/OpenLP-1.9.6-bzr1684.dmg (this won't work on 10.5 though)

wezlo (revwez) wrote :

Raul sent me a build yesterday which worked - is this the same one?

Sent from my iPad

On Jul 14, 2011, at 12:31 AM, Matthias Hub <email address hidden> wrote:

> matysek, that looks very good! wezlo can you try the latest build from
> http://www.matthiashub.de/tmp/openlp/OpenLP-1.9.6-bzr1684.dmg (this
> won't work on 10.5 though)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/648472
>
> Title:
> Jpegs can't be used as backgrounds in MacOS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openlp/+bug/648472/+subscriptions

Matthias Hub (matthiashub) wrote :

No, it should be a little bit more towards an official build with a correct splash screen etc...

wezlo (revwez) wrote :

gotcha, I'll install it now

On Thu, Jul 14, 2011 at 7:08 AM, Matthias Hub <email address hidden>wrote:

> No, it should be a little bit more towards an official build with a
> correct splash screen etc...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/648472
>
> Title:
> Jpegs can't be used as backgrounds in MacOS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openlp/+bug/648472/+subscriptions
>

wezlo (revwez) wrote :

Jpegs work - when I started it up it was trying to display on a single
screen by default - I dragged the control window over until I could toggle
the "go live" setting, but if it's default behavior some people who are
working on single-screen setups to configure services might be confused...

Wes

On Thu, Jul 14, 2011 at 7:16 AM, Wes Allen <email address hidden> wrote:

> gotcha, I'll install it now
>
> On Thu, Jul 14, 2011 at 7:08 AM, Matthias Hub <email address hidden>wrote:
>
>> No, it should be a little bit more towards an official build with a
>> correct splash screen etc...
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/648472
>>
>> Title:
>> Jpegs can't be used as backgrounds in MacOS
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/openlp/+bug/648472/+subscriptions
>>
>
>

tags: added: support-system
Matthias Hub (matthiashub) wrote :

just tried to build a new version on 10.5 with the latest pyinstaller: that works also for me on my 10.6 test system with JPEG support (yay!), please test the latest weekly build

wezlo (revwez) wrote :

Link?

Sent from my iPad

On Jul 17, 2011, at 4:50 AM, Matthias Hub <email address hidden> wrote:

> just tried to build a new version on 10.5 with the latest pyinstaller:
> that works also for me on my 10.6 test system with JPEG support (yay!),
> please test the latest weekly build
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/648472
>
> Title:
> Jpegs can't be used as backgrounds in MacOS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openlp/+bug/648472/+subscriptions

Matthias Hub (matthiashub) wrote :

sorry: http://openlp.org/files/latest.dmg (that's always the latest OS X build URL)

wezlo (revwez) wrote :

thanks, jpegs are still working...

On Sun, Jul 17, 2011 at 3:57 PM, Matthias Hub <email address hidden>wrote:

> sorry: http://openlp.org/files/latest.dmg (that's always the latest OS X
> build URL)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/648472
>
> Title:
> Jpegs can't be used as backgrounds in MacOS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openlp/+bug/648472/+subscriptions
>

Andreas Preikschat (googol) wrote :

Hello,

Is this now fixed? Anything to be done?

The following things have to be done/looked at:
- the ticket in the support system
- maybe a short blog post?

Cheers

Matthias Hub (matthiashub) wrote :

Hello Andreas, yes, this is now fixed! I am currently preparing an official merge proposal to build correctly on Snow Leopard, thus I did not publish anything yet. Do you think we should already write a blog post pointing to "latest.dmg"?

Andreas Preikschat (googol) wrote :

I think we should not use the nightly link.

Matthias Hub (matthiashub) wrote :
Changed in openlp:
status: In Progress → Fix Released
Andreas Preikschat (googol) wrote :

The documentation has to be updated to reflect the changes: http://manual.openlp.org/troubleshooting.html#i-have-jpg-images-and-they-will-not-work-on-my-system

I do not know if there are any issues with XP :-(
Maybe somebody in IRC knows...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.