OpenLP - Worship Presentation Software

Add two songs in a row, and the first one gets lost

Reported by Jonathan Corwin on 2010-09-16
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenLP
Critical
Raoul Snyman

Bug Description

As reported by milleja46 on IRC/dev mailing list, and duplicated by me in r1028 Windows exe.

Add a simple song (title/verse/author) and save. Add another song and save. The first song no longer appears in the media manager, and doesn't return after a restart either.

Related branches

Joshua Miller (milleja46) wrote :

Now i've yet to test this when in a service, as far as i know it only happens in a no service mode. If someone has checked on it i kind of would like to know if so i would like to know another way to put songs in, as a sqlite file like i've found before or otherwise till this is fixed. As i would very much so like to use this for sunday, and possibly when a club starts up on tuesdays. But i want to find a way around this bug until fixed, because i know a song import with sqlite allows multiple songs.

Jonathan Corwin (j-corwin) wrote :

There is no guarantee that even if we fix it by the weekend that an exe will be produced.

One workaround for now if you only have a few songs is to restart OpenLP after adding each one (a slow process I know).

Alternatively go back to the original 1.9.2 (on the OpenLP downloads page) where adding a second song does work. Unfortunately I think you'd have to clear down your registry settings and song database first, so you may not want to do that.

Yet another is to add the songs in v1.2.5, then export them and import them into v2. If your version doesn't have the openlp.org v1 import (it might do, I can't remember) then the latest dev build can be found at: http://openlp.org/files/OpenLP-1.9.2-bzr1035-setup.exe

Changed in openlp:
assignee: nobody → Raoul Snyman (raoul-snyman)
Changed in openlp:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers