Unable to open presentation from an opened service file

Bug #605655 reported by Jonathan Corwin on 2010-07-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
Fix Released
High
Unassigned

Bug Description

From: http://openlp.org/en/forums/openlp_20/bug_reports/powerpoint_on_reload.html

I seem to be experiencing a bug in OpenLP 2 when using a powerpoint presentation. I have activated the plugin and set it to use powerpoint in the settings tab.
I seem to be able to add the presentation OK it runs fine once added to the service.
However, when I reload the service after restarting OpenLP the powerpoint in the service now has an X by it. When I try and play it I get this message... "Your item cannot be displayed as there is no handler to display it". When I look in the presentation tab my powerpoint tab displays the correct presenation which I can add once more to the presentation which works fine until I save the presentation and come back later.

Related branches

Tim Bentley (trb143) wrote :

The service manager attempts (and fails) to detect media it needs to play and that fact that the player is not available.
This did work in tests but may well not work too well.

Test case .

- Add a powerpoint to a service and save it
- turn off presentations and restart openlp
- load service and you should have red cross.
- turn on presentations and restart openlp
- load service and its should play.

Simples.

Changed in openlp:
assignee: Jonathan Corwin (j-corwin) → nobody
Jon Tibble (meths) on 2010-07-31
Changed in openlp:
status: Confirmed → Fix Committed
Jon Tibble (meths) wrote :

Released in trunk revision 980

Changed in openlp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers