Bibles plugin fails to load due to invalid "last search type" value

Bug #1695268 reported by Azaziah on 2017-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
High
Azaziah

Bug Description

I just started 2.4.6 normally on win 10, but only "songs" were visible in Library. All of the plugins are activated in the plugin manager.

On closing the program, the following traceback appears:

Traceback (most recent call last):
  File "openlp\core\ui\mainwindow.py", line 1091, in closeEvent
  File "openlp\core\ui\mainwindow.py", line 1129, in clean_up
  File "openlp\core\lib\pluginmanager.py", line 189, in finalise_plugins
  File "C:\Program Files (x86)\OpenLP\plugins\bibles\bibleplugin.py", line 100, in finalise
    action_list.remove_action(self.import_bible_item, UiStrings().Import)
  File "openlp\core\utils\actions.py", line 300, in remove_action
  File "openlp\core\utils\actions.py", line 117, in remove
TypeError: 'QAction' object does not support indexing

The same traceback also appears when trying to de-activate the "Bible" plugin
(The status does not change, but combobox item does)

If trying to activate the plugin, the following traceback appears:

Traceback (most recent call last):
  File "openlp\core\ui\pluginform.py", line 136, in on_status_combo_box_changed
  File "openlp\core\lib\plugin.py", line 186, in toggle_status
  File "C:\Program Files (x86)\OpenLP\plugins\bibles\bibleplugin.py", line 84, in initialise
    super(BiblePlugin, self).initialise()
  File "openlp\core\lib\plugin.py", line 278, in initialise
  File "openlp\plugins\bibles\lib\mediaitem.py", line 319, in initialise
  File "openlp\core\common\settings.py", line 436, in value
TypeError: unable to convert a QVariant back to a Python object

Deleting the OpenLP data folder does not fix this issue.
The causes for this bug are still unclear, 2.4.6 used to work normally.

Related branches

Azaziah (suutari-olli) wrote :
description: updated
Azaziah (suutari-olli) wrote :

Bibles data folder.

Azaziah (suutari-olli) wrote :

Log without any bibles in data folder

Azaziah (suutari-olli) on 2017-06-03
summary: - Bibles plugin fails to load and breaks the Library
+ Bibles plugin fails to load due to invalid "last search type" value
Azaziah (suutari-olli) wrote :

Note:

2.4.6 stores "last search type" as:
REG_DWORD (1/0) to registry.

Where as the problematic registry type was:
REG_BINARY instead of REG_DWORD.

Where did this invalid value come from?
Recent changes to trunk?

Phill (phill-ridout) wrote :

The value comes from line 250 of the diff at https://code.launchpad.net/~phill-ridout/openlp/saved_bible_verses/+merge/324674

This should only affect you if you go from a newer version of openlp to an older version, and as we don't support downgrading I'm going to set this as 'wont fix'

If you're downgrading for development purposes, its worth noting that you can use the -p argument when running openlp.py to run it in portable mode (on windows your settings will be stored in a ini file instead of the registry.

Changed in openlp:
status: New → Won't Fix
Azaziah (suutari-olli) on 2017-06-04
Changed in openlp:
status: Won't Fix → In Progress
assignee: nobody → Azaziah (suutari-olli)
Tim Bentley (trb143) on 2017-06-08
Changed in openlp:
status: In Progress → Fix Committed
milestone: none → 2.5.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers