Song Editor alway saves theme

Bug #1666006 reported by Gyuris Gellért on 2017-02-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenLP
Undecided
Unassigned

Bug Description

OS:
Ubuntu 16.10

OpenLP
2.4.5 (Previous version was not affected)
PPA: http://ppa.launchpad.net/openlp-core/release/ubuntu yakkety main
Installed version: 2.4.5-1~16.10

Step to reproduce
1. Add a new Song.
2. Type some title and text for Lyrics, and add one author. Save it.
3. Reopen it: There is an unwanted theme selected in 3td tab. Theme is the first theme in the list.

Can anyone confirm this? Is this a database bug in my case, or a program bug?

Timothy Cooper (timothycooper) wrote :

I can confirm this. OpenLP 2.4.5 (not present in 2.4.4 or earlier), running on Windows 10 x64.

I also found this behavior occurs when editing a song that doesn't have a theme specified. OpenLP assigns the first (alphabetical) theme to the song upon saving, rather than applying the appropriate default theme.

Perhaps the recent update (accidentally?) changed Song/Service/Global theme levels? My work around was to apply our typical theme to each song individually. :/

rev. john whitney (4-jc) wrote :

I also confirm this.
in previous vesions the dialog defaults to no theme selected as first entry.
looks like it now selects the first theme by default, rather than a 0 or nul entry.
you can explicitly delete and save song, but selecting any other diolog box before saving song causes first theme in list to be selected again.

On theme drop down in dialog no longer a blank entry at top of list which had the effect previously of 'use default'

Could this be as a result of input validation?

Simon Hanna (thelinuxguy) wrote :

I can also confirm this is happening on 2.4.5 (archlinux)
BUT it appears to be fixed in trunk

Stefan Seidel (seidler2547) wrote :

Yes, we've had some very "interesting" services recently because our first theme is a "blank/black" theme. It's how we have a completely black custom slide to put between service items. A couple of new and edited songs now have this black theme, so they don't show. Current workaround is to change to "Service Level" and loose the blank slide and custom fonts on custom slides. Better than having no words up at all!

For me 2.4.6 works well (https://get.openlp.org/2.4.6/openlp_2.4.6-1_all.deb), bug disappeared.
Can anyone confirm?

Stefan Seidel (seidler2547) wrote :

Correct, on 2.4.6 (at least on Linux) the theme can be removed and is not automatically added when a song is edited.

Samuel Mehrbrodt (sam92) on 2017-06-01
Changed in openlp:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers