Song Editor saves wrong author

Bug #1666005 reported by Gyuris Gellért on 2017-02-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenLP
Status tracked in Trunk
2.4
Fix Released
High
Raoul Snyman
Trunk
Fix Committed
High
Raoul Snyman

Bug Description

OS:
Ubuntu 16.10

OpenLP
2.4.5 (Previous version was not affected)
PPA: http://ppa.launchpad.net/openlp-core/release/ubuntu yakkety main
Installed version: 2.4.5-1~16.10

Step to reproduce
1. Add a new Song.
2. Type some text for Lyrics, and add one author. Save it. That's OK.
3. Edit newly added song. Add another author. When you click on "Add" in the list displays wrong author (next to wanted). After saving this remains.

Can anyone confirm this? Is this a database bug in my case, or a program bug?

Related branches

Similar: #1669007

Changed in openlp:
status: New → Confirmed
Changed in openlp:
status: Confirmed → Fix Committed
importance: Undecided → High
assignee: nobody → Raoul Snyman (raoul-snyman)

I confirm that this is fixed in 2.4.6. You can close this, if you wish, Raoul,

Raoul Snyman (raoul-snyman) wrote :

Thanks for confirming. The bug will stay open because it's also tracked in 2.5. When 2.5.1 or 2.6 are released, the bug will be closed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers