Not Handling OSErrors

Bug #1650910 reported by Raoul Snyman on 2016-12-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenLP
Low
Phill

Bug Description

We don't handle OSErrors. Things like "No space left on device" or "Permission denied (read only file)".

Traceback (most recent call last):
  File "openlp/core/ui/servicemanager.py", line 720, in decide_save_method
  File "openlp/core/ui/servicemanager.py", line 497, in save_file
  File "tempfile.py", line 278, in mkstemp
  File "tempfile.py", line 207, in _mkstemp_inner
OSError: [Errno 28] No space left on device: '/var/folders/j2/wmnnfhhn7j32slfp0t7zfy6h0000gn/T/openlp_rap_a2ly.osz'

Traceback (most recent call last):
  File "D:\OpenLP_Development\OpenLP_Code\2.2\openlp\core\ui\servicemanager.py", line 723, in decide_save_method
  File "D:\OpenLP_Development\OpenLP_Code\2.2\openlp\core\ui\servicemanager.py", line 662, in save_local_file
  File "c:\Python33\lib\shutil.py", line 227, in copy
  File "c:\Python33\lib\shutil.py", line 110, in copyfile
PermissionError: [Errno 13] Permission denied: 'C:\\Users\\NCF-AV\\Documents\\OpenLP\\Services\\(template).oszl'

Related branches

Timothy Cooper (timothycooper) wrote :

The Traceback shown here came from our church's laptop (unless someone else also named their user account NCF-AV). I'll provide more info if requested. We currently use a Read Only system flag to prevent file "(template).oszl" from being accidentally overwritten (since OpenLP doesn't have Templates at this time).

Tim Bentley (trb143) on 2017-01-31
Changed in openlp:
status: New → Won't Fix
Raoul Snyman (raoul-snyman) wrote :

Actually, my point still stands. An exception dialog should not show up, we should inform the user of the problem instead.

Changed in openlp:
status: Won't Fix → Confirmed
Phill (phill-ridout) on 2017-10-09
Changed in openlp:
importance: Undecided → Low
Phill (phill-ridout) on 2019-03-03
Changed in openlp:
status: Confirmed → In Progress
assignee: nobody → Phill (phill-ridout)
Phill (phill-ridout) on 2019-03-17
Changed in openlp:
status: In Progress → Fix Committed
Tim Bentley (trb143) on 2019-03-17
Changed in openlp:
milestone: none → 2.9.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers