Traceback error when attached media (to song) not found

Bug #1559336 reported by Richard Graham on 2016-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
Medium
Hamilton Chevez
2.4
Undecided
Raoul Snyman

Bug Description

Windows 8.1, OLP 2.4.

When there is a media item attached to a song, if the song is not found when saving the song then a traceback error appears with the below text. It's quite obvious that it is for this reason, although - as the traceback text also implies - in my situation here, the database was copied from Mac OSX onto Windows which I agree may have caused the issue!

The expected result would be a 'normal' error dialogue to say that the file was not found, probably with the option to remove the attached file from the database.

Traceback (most recent call last):
  File "openlp\plugins\songs\forms\editsongform.py", line 986, in accept
  File "openlp\plugins\songs\forms\editsongform.py", line 1057, in save_song
  File "shutil.py", line 108, in copyfile
FileNotFoundError: [Errno 2] No such file or directory: "/Users/richard/Library/Application Support/openlp/Data/songs/audio/194/01 It's Rising Up.mp3"

Related branches

Tomas Groth (tomasgroth) on 2016-03-21
Changed in openlp:
importance: Undecided → Medium
status: New → Confirmed
Changed in openlp:
assignee: nobody → Hamilton Chevez (dbgchev01)
Tomas Groth (tomasgroth) on 2016-05-10
Changed in openlp:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers