Print Service no longer works in 2.4

Bug #1547307 reported by David Wales on 2016-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
Medium
Unassigned

Bug Description

Mac OS X 10.11.3

OpenLP 2.4 Mac app bundle. (Works fine in trunk!)

How to reproduce:

1. Create service
2. Click File -> Print Service
3. In the Print Service dialog, click "Print".
4. The service will not print.
5. If you run OpenLP from Terminal, you will see this printed to stdout:
"QPrintDialog: Cannot be used on non-native printers"

Expected outcome:
The system print dialog will appear, and you will be able to print the service.

Note that this is a regression. It used to work perfectly in 2.2.

EDIT: I have just tested with the source version of OpenLP in trunk, and Print Service is still working perfectly, the way it has always worked.

But the Mac app isn't working.

I have even tried running the Mac app in portable mode to eliminate the possibility that there is a data corruption which is preventing the print dialog from working.

However, even with the same service file, and the same data, the Mac app won't print, but the latest trunk will.

David Wales (daviewales) on 2016-02-19
description: updated
David Wales (daviewales) on 2016-02-19
tags: added: regression
description: updated
Tim Bentley (trb143) on 2016-02-19
Changed in openlp:
status: New → Confirmed
Tomas Groth (tomasgroth) wrote :

I've been able to reproduce this on windows running from the 2.4 install build.
The problem seems to be that a required qt5 print library isn't bundled. On windows I think we need to add qt5_plugins\printsupport\windowsprintersupport.dll
Not sure if this is a PyInstaller issue or our packaging script that needs to include it manually.

Changed in openlp:
importance: Undecided → Medium
Tomas Groth (tomasgroth) wrote :

I've created an issue in the PyInstaller bugtracker for this: https://github.com/pyinstaller/pyinstaller/issues/1896

And it’s already fixed!
That was quick!

> On 23 Mar 2016, at 8:16 AM, Tomas Groth <email address hidden> wrote:
>
> I've created an issue in the PyInstaller bugtracker for this:
> https://github.com/pyinstaller/pyinstaller/issues/1896
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1547307
>
> Title:
> Print Service no longer works in 2.4
>
> Status in OpenLP:
> Confirmed
>
> Bug description:
> Mac OS X 10.11.3
>
> OpenLP 2.4 Mac app bundle. (Works fine in trunk!)
>
> How to reproduce:
>
> 1. Create service
> 2. Click File -> Print Service
> 3. In the Print Service dialog, click "Print".
> 4. The service will not print.
> 5. If you run OpenLP from Terminal, you will see this printed to stdout:
> "QPrintDialog: Cannot be used on non-native printers"
>
> Expected outcome:
> The system print dialog will appear, and you will be able to print the service.
>
> Note that this is a regression. It used to work perfectly in 2.2.
>
> EDIT: I have just tested with the source version of OpenLP in trunk,
> and Print Service is still working perfectly, the way it has always
> worked.
>
> But the Mac app isn't working.
>
> I have even tried running the Mac app in portable mode to eliminate
> the possibility that there is a data corruption which is preventing
> the print dialog from working.
>
> However, even with the same service file, and the same data, the Mac
> app won't print, but the latest trunk will.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openlp/+bug/1547307/+subscriptions

Tomas Groth (tomasgroth) wrote :

A fix has been commited to pyinstaller.

Changed in openlp:
status: Confirmed → Fix Committed
Tomas Groth (tomasgroth) on 2016-07-18
Changed in openlp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers