No Shortcuts work in 2.3.2

Bug #1533246 reported by Wolodja Moros on 2016-01-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
Undecided
Raoul Snyman

Bug Description

I installed OpenLP 2.3.2 on a Debian Jessie machine ( I have to use the backports ) and the first thing I noticed that no shortcuts work anymore. Whatever I tried nothing happen.

Environment
Debian Jessie
OpenLP 2.3.2
Gnome 3.16

Sincerely Jonatan

Related branches

Wolodja Moros (wolodja-moros) wrote :

Commands to install OpenLP on Debian 8:

apt-get -t jessie-backports install python3-alembic python3-editor python3-sqlalchem
apt-get install libjs-jquery libjs-jquery-mobile python3-bs4 python3-chardet python3-enchant python3-lxml python3-mako python3-pyqt5 python3-pyqt5.qtmultimedia python3-pyqt5.qtopengl python3-pyqt5.qtsvg python3-pyqt5.qtwebkit python3-dbus python3-xdg python3-uno
dpkg -i openlp_2.3.2-1_all.deb

Wolodja Moros (wolodja-moros) wrote :

Sorry,

I the first command going a y lost. Correct version is :

apt-get -t jessie-backports install python3-alembic python3-editor python3-sqlalchemy

Raoul Snyman (raoul-snyman) wrote :

I'm definitely seeing some weirdities too. We'll take a look. Thanks.

Tim Bentley (trb143) on 2016-02-05
Changed in openlp:
milestone: none → 2.2.2
status: New → Fix Committed
assignee: nobody → Raoul Snyman (raoul-snyman)
Tim Bentley (trb143) on 2016-02-05
Changed in openlp:
milestone: 2.2.2 → 2.3.3
Tim Bentley (trb143) on 2016-02-06
Changed in openlp:
status: Fix Committed → Fix Released
Wolodja Moros (wolodja-moros) wrote :

This problems seems to be not solved.
On my new install (Debian 8) the short cut does not work, but if i delete the shortcut (remove for example ctrl n from new service) press Ok and set the same short cut again it works.
Maybe this is a possible work around.

Changed in openlp:
status: Fix Released → New
Wolodja Moros (wolodja-moros) wrote :

New information:
Is install Openlp new and remove the old configuration folder.
And now to the new Information. The problem exist still in the new installation, but I have found a better workaround. Just delete the alternative shortcut and everything work fine.
Every shortcut with out a alternative shortcut work perfect from the start.

So the solution is to delete all alternative shortcuts and everything work fine.

Tim Bentley (trb143) on 2016-02-08
Changed in openlp:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers