Expanding or Collapsing a Song in ServiceManager raises an Exception

Bug #1532169 reported by Simon Hanna on 2016-01-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
High
Tomas Groth

Bug Description

When expanding or Collapsing a Song in ServiceManager a IndexError occurs.
This only happens when using the buttons in the Service Manager.
I guess the error occurs because of the -1 when accessing the items.
However the -1 is being used 5 times all over the class.
I'm not sure about the reason behind the -1 in the first place

Related branches

lp:~tomasgroth/openlp/presentation-fixes24
Tim Bentley: Approve on 2016-01-14
Raoul Snyman: Approve on 2016-01-14
Tomas Groth (tomasgroth) on 2016-01-11
Changed in openlp:
importance: Undecided → High
status: New → Confirmed
Tomas Groth (tomasgroth) on 2016-01-12
Changed in openlp:
assignee: nobody → Tomas Groth (tomasgroth)
status: Confirmed → In Progress
Tim Bentley (trb143) wrote :

-1 I think meant no set or something like that!

Tomas Groth (tomasgroth) wrote :

The problem seems to be that we try to expand the child items as well, which causes the traceback since we set an 'expanded' attribute on the serviceitemlist, but that list only contains the root items.
I'm guessing this shows up now because the signaling has changed from qt4 to qt5.

Tim Bentley (trb143) on 2016-01-14
Changed in openlp:
milestone: none → 2.4.0
status: In Progress → Fix Committed
Tim Bentley (trb143) on 2016-02-05
Changed in openlp:
milestone: 2.4.0 → 2.3.3
Tim Bentley (trb143) on 2016-02-06
Changed in openlp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers