The presentation display isn't updated on windows

Bug #1531319 reported by Tomas Groth on 2016-01-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenLP
Critical
Tomas Groth

Bug Description

Seen on Windows 10 with OpenLP 2.3.1.
When presenting a song, bible-text. custom-slide or group of images the presentation display does not update beyond the first slide. The small "mirror" in the slidecontroller is updated though.
This seems to be a windows-only bug.

Related branches

lp:~tomasgroth/openlp/importer-fixes
Tim Bentley: Approve on 2016-01-09
lp:~tomasgroth/openlp/23bugfixes
Tomas Groth: Approve on 2016-01-24
Tim Bentley: Approve on 2016-01-23
lp:~tomasgroth/openlp/23bugfixes2
Tim Bentley: Approve on 2016-02-06
Raoul Snyman: Approve on 2016-02-06
lp:~tomasgroth/openlp/refix-win-display
Tim Bentley: Approve on 2016-02-29
Tomas Groth (tomasgroth) on 2016-01-06
description: updated
Tomas Groth (tomasgroth) on 2016-01-09
Changed in openlp:
assignee: nobody → Tomas Groth (tomasgroth)
status: New → In Progress
Tomas Groth (tomasgroth) on 2016-01-09
Changed in openlp:
milestone: none → 2.3.2
status: In Progress → Fix Committed
Tim Bentley (trb143) on 2016-01-10
Changed in openlp:
status: Fix Committed → Fix Released
Tomas Groth (tomasgroth) wrote :

It turns our this wasn't fixed after all...
It seems to be connected to the enabled mediaplayers. If VLC is enabled the bug appears. (Feel free to elaborate/correct me if I got this wrong.)

Changed in openlp:
status: Fix Released → Confirmed
Tomas Groth (tomasgroth) on 2016-01-18
Changed in openlp:
assignee: Tomas Groth (tomasgroth) → nobody
milestone: 2.3.2 → none
Tomasss (tomas-spam) wrote :

I tried to turn off vlc, webkit, but slide isn't updated.

Tomas Groth (tomasgroth) wrote :

I did some testing yesterday, and it seems you must turn of both VLC and the SystemPlayer to get the the slides to update. It works with the webkit player.

That is interesting as the preview is an image taken from the main screen
after it had been updated.
On 19 Jan 2016 8:25 am, "Tomas Groth" <email address hidden> wrote:

> I did some testing yesterday, and it seems you must turn of both VLC and
> the SystemPlayer to get the the slides to update. It works with the
> webkit player.
>
> --
> You received this bug notification because you are a member of OpenLP
> Core, which is subscribed to OpenLP.
> https://bugs.launchpad.net/bugs/1531319
>
> Title:
> The presentation display isn't updated on windows
>
> Status in OpenLP:
> Confirmed
>
> Bug description:
> Seen on Windows 10 with OpenLP 2.3.1.
> When presenting a song, bible-text. custom-slide or group of images the
> presentation display does not update beyond the first slide. The small
> "mirror" in the slidecontroller is updated though.
> This seems to be a windows-only bug.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openlp/+bug/1531319/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openlp-core
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~openlp-core
> More help : https://help.launchpad.net/ListHelp
>

Tomas Groth (tomasgroth) on 2016-01-23
Changed in openlp:
assignee: nobody → Tomas Groth (tomasgroth)
status: Confirmed → In Progress
Tim Bentley (trb143) on 2016-01-24
Changed in openlp:
status: In Progress → Fix Committed
milestone: none → 2.4.0
Tim Bentley (trb143) on 2016-02-05
Changed in openlp:
milestone: 2.4.0 → 2.3.3
Tim Bentley (trb143) on 2016-02-06
Changed in openlp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers