ZionWorks import fails in OpenLP 2.2

Bug #1510282 reported by Tomas Groth on 2015-10-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
Status tracked in Trunk
Trunk
Fix Released
Medium
Tomas Groth

Bug Description

When trying to import the CSV generated from ZionWorks song database, the import fails with this error message:

The following songs could not be imported:
- Error reading CSV file. (Line 0: iterator should return strings, not bytes (did you open the file in text mode?))

The problem is that the code doing the import hasen't been updated to work with python3.

Related branches

Tim Bentley (trb143) on 2015-10-30
Changed in openlp:
milestone: none → 2.2.1
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers