Powerpoint / object has no attribute 'slidenumber'

Bug #1490508 reported by Azaziah on 2015-08-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
Medium
Tomas Groth

Bug Description

Runnin 2.1.6 Portable Win 8.1 + Office 2013 + Libre

I imported one .ppt file and sent it to live, a traceback appeared:

I was able to re-produce it with the same file few times but then it started working after some restarts and other files in between. I don’t have the permission to share this file but here’s some tracebacks:

Traceback (most recent call last):
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\lib\mediamanageritem.py", line 462, in on_double_clicked
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\lib\mediamanageritem.py", line 503, in on_live_click
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\lib\mediamanageritem.py", line 530, in go_live
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\ui\slidecontroller.py", line 779, in add_service_item
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\ui\slidecontroller.py", line 894, in _process_item
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\ui\maindisplay.py", line 429, in build_html
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\common\registry.py", line 137, in execute
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\ui\slidecontroller.py", line 956, in on_slide_unblank
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\ui\slidecontroller.py", line 975, in on_blank_display
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\ui\slidecontroller.py", line 1036, in blank_plugin
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\common\registry.py", line 137, in execute
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\messagelistener.py", line 464, in unblank
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\messagelistener.py", line 274, in unblank
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\messagelistener.py", line 100, in activate
AttributeError: 'PowerpointDocument' object has no attribute 'slidenumber'

I tried to use that presentation nevertheless and other tracebacks appeared:

Traceback (most recent call last):
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\messagelistener.py", line 471, in timeout
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\messagelistener.py", line 282, in poll
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\presentationcontroller.py", line 281, in poll_slidenumber
TypeError: unsupported operand type(s) for -: 'NoneType' and 'int'

and

Traceback (most recent call last):
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\ui\slidecontroller.py", line 1067, in on_slide_selected
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\ui\slidecontroller.py", line 1091, in slide_selected
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\core\common\registry.py", line 137, in execute
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\messagelistener.py", line 370, in slide
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\messagelistener.py", line 125, in slide
  File "D:\OpenLP_Development\OpenLP_Code\2.1\openlp\plugins\presentations\lib\powerpointcontroller.py", line 424, in goto_slide
KeyError: 2

Related branches

lp:~tomasgroth/openlp/23bugfixes2
Tim Bentley: Approve on 2016-02-06
Raoul Snyman: Approve on 2016-02-06
Tomas Groth (tomasgroth) wrote :

The problem is most likely that the loading of that presentation failed. Was there any special content in the presentation?

Phill (phill-ridout) wrote :

The other thing that I have seen, there is a bug reported somewhere, is that OpenLP choaks when powerpoint shows a dialog window, for example when powerpoint hasn't been used before.

Changed in openlp:
importance: Undecided → Low
Tomas Groth (tomasgroth) wrote :

There has been quite a few support requests from users experiencing the "object has no attribute 'slidenumber'" traceback, so we should probably try to fix this. As I see it there are (at least) 2 things that could cause this:
1. Loading of the presentation failed, so PowerpointDocument wasen't initilized properly
2. The presentation was loaded by Impress, creating an ImpressDocument, which causes issues when trying to start this with PowerPoint.

Changed in openlp:
importance: Low → Medium
status: New → Confirmed
Tomas Groth (tomasgroth) on 2016-02-05
Changed in openlp:
assignee: nobody → Tomas Groth (tomasgroth)
status: Confirmed → In Progress
Tim Bentley (trb143) on 2016-02-06
Changed in openlp:
milestone: none → 2.3.3
status: In Progress → Fix Committed
Tim Bentley (trb143) on 2016-02-06
Changed in openlp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers