KDE Plasma 5 is breaking the look of OpenLP

Bug #1404669 reported by Tim Bentley on 2014-12-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenLP
High
Raoul Snyman

Bug Description

Need to be checked on other platforms.
In 2.0 all the lists in the media item are white by default.

In 2.1 Song and Bible are white.
The rest are grey not sure why and had a good look to see what has changed.

This looks bad!
If may be a Fedora thing but not convinced.

Related branches

lp:~thelinuxguy/openlp/fix-stylesheet
Raoul Snyman: Approve on 2016-01-11
Tim Bentley: Approve on 2016-01-11
Tomas Groth (tomasgroth) wrote :

This isn't an issue on windows using the latest build. They are all white, unless the "alternating row colors" is enabled, in which case they alternate between white and grey, as expected.

Tomas Groth (tomasgroth) wrote :

Just tested on Ubuntu 14.04, where the lines are always alternating between white and grey, no matter if the "alternating row colors" setting is enabled or not.

Tim Bentley (trb143) wrote :

Here are some screen shots of fedora.
A new build this week as I have just replaced the hard disk.

Tim Bentley (trb143) wrote :
Tim Bentley (trb143) wrote :
Tim Bentley (trb143) wrote :
Tim Bentley (trb143) wrote :
Phill (phill-ridout) on 2014-12-28
Changed in openlp:
importance: Undecided → Low
Tim Bentley (trb143) wrote :

Raising importance as KDE is changing things

Running 2.1.2 on new Fedora 21 with KDE plasma 5.2 removes all the text on the media labels. All the icons are moved to the middle.

Running supermacs QT5 code on Fedora 21 fixes this bug.

Fedora 22 (may) will be moving to plasma 5.2 so a developer will be on a qt5 desktop developing a qt4 app which is not ideal.

Changed in openlp:
status: New → Confirmed
importance: Low → High
summary: - Backgrounds of Media Items
+ KDE Plasma 5 is breaking the look of OpenLP
Tim Bentley (trb143) wrote :

Screen Shot

Changed in openlp:
milestone: none → 2.3.0
Tim Bentley (trb143) on 2015-12-28
Changed in openlp:
milestone: 2.3.0 → none
Tim Bentley (trb143) on 2016-01-09
Changed in openlp:
assignee: nobody → Raoul Snyman (raoul-snyman)
milestone: none → 2.3.2
status: Confirmed → Fix Committed
Tim Bentley (trb143) on 2016-01-10
Changed in openlp:
milestone: 2.3.2 → none
status: Fix Committed → Confirmed
Simon Hanna (thelinuxguy) wrote :

I went asking on #kde and #qt about this issue:
It's not a bug, it's a feature in plasma.

If I got it right, plasma either displays the icons or the text, not both. This behavior can only be changed by having the users themselves edit their plasma configurations.

My personal opinion that the stylesheets improve the looks by a lot!
The 'Fix' would probably be dropping the icons, and only display a text. I don't think the icons are necessary in the media manager, what do you think?

I don't yet know how easy it is to just disable the icons in the mediamanager

Tim Bentley (trb143) wrote :

If it is one or the other then text would be preferable.

Tim Bentley (trb143) on 2016-01-11
Changed in openlp:
milestone: none → 2.4.0
status: Confirmed → Fix Committed
Tim Bentley (trb143) on 2016-02-05
Changed in openlp:
milestone: 2.4.0 → 2.3.3
Tim Bentley (trb143) on 2016-02-06
Changed in openlp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers