disappearing dialog 'Select Presentation(s)' on OSX

Bug #1168493 reported by matysek on 2013-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenLP
Low
Unassigned

Bug Description

With the development version on OS X I'm not able to load images or any media since dialog 'Select Presentation(s)' and similar dialogs by media and image plugins disappear immediately without any time to be able to select any file.

- It happens mostly when the powerpoint integration is disabled.
- also last time it happened even with presentations plugin disabled.
- so it seems it's not related to the powerpoint integration

My guess would be that something is stealing focus of the openlp window or pyqt generates any signals that causes this dialog to disappear.

Phill (phill-ridout) wrote :

Matysek, could this be related to #1266270?

tags: added: gui osx
matysek (mzibricky) wrote :

It could be related to #1266270.

Was anyone else able to reproduce this issue?

Jonathan Springer (springermac) wrote :

I can reproduce it sometimes but I haven't found a way to make reproducible every time.

Jonathan Springer (springermac) wrote :

This seems to be fixed in PyQt5 when testing with Raoul's pyqt5 branch.

Phill (phill-ridout) wrote :

As we're not on PyQt5 (yet) and this is confirmed in https://bugs.launchpad.net/openlp/+bug/1266270 I've set it to confirmed

tags: added: pyqt5
Changed in openlp:
status: New → Confirmed
importance: Undecided → Low
Changed in openlp:
milestone: none → 2.3.0
Tim Bentley (trb143) on 2015-12-28
Changed in openlp:
milestone: 2.3.0 → none
Tim Bentley (trb143) on 2017-05-31
tags: removed: gui osx pyqt5
Phill (phill-ridout) wrote :

2.4.x is running PyQt5 could somebody test if this bug still exists?

Changed in openlp:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers