Presentation preview shows desktop when live shows desktop

Bug #1080596 reported by Dmitriy Marmyshev on 2012-11-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenLP
Medium
Ian Knight

Bug Description

When u send to live any item, and then blank screen or bg them or show desktop on live, and then add a presentation to preview Preview Controller does not shoes thumbnails of the presentation and shows what is on live screen.

Win7, PPT-2007. OLP 1.9.12.

Related branches

tags: added: presentations
Tim Bentley (trb143) wrote :

Had you restarted OpenLP or was it the same session as 1080597?

tags: removed: presentations
Dmitriy Marmyshev (marmyshev) wrote :

Yes, it was the same session. We didnt restart OpenLP. To restart we needed to save the service - but this was impossible, because of video.

Raoul Snyman (raoul-snyman) wrote :

I can reproduce this.

Changed in openlp:
status: New → Confirmed
importance: Undecided → Medium
Ian Knight (knightrider0xd) wrote :

The preview screen reflecting the live screen appears to happen for presentations regardless of the order of loading items and/or blanking screens.

Changed in openlp:
assignee: nobody → Ian Knight (knightrider0xd)
Changed in openlp:
status: Confirmed → In Progress
Tim Bentley (trb143) on 2016-05-16
Changed in openlp:
status: In Progress → Fix Committed
milestone: none → 2.5.1
Harnarine Ramnarine (haram) wrote :

My OpenLp program has a problem. whenever I import a Powerpoint presentation to the Madia Manager and preview it there appears the document on the top pane but at the bottom pane I see the full page of the openLp program. further to this when I call the powerpoint document to the live screen the document does not appear, istead the computer destop image or wall paper appears instead. when i choose to close the live show then appears a window appears stating" the Powerpoint document cannot integrate with the program of OpenLp and if I wish to continue I need to reimport the document again". when I tried reimporting the same thing happens again. This is preventing me from making my presentation live during church services. I need your help to correct this situation. Thanks.

Ian Knight (knightrider0xd) wrote :

Hi Harnarine,

Sorry about the delay; I'm only a small contributor to this project and haven't touched it in about a year.

It sounds like you're describing 3 separate issues here:
1) The contents of the bottom pane when previewing not displaying correctly.
2) The live screen not displaying correctly when the PowerPoint is running.
3) The error message that appears when closing the PowerPoint.

This particular Bug only applies to 1) and will be fixed from version 2.5.1. Unless you're running a development version you may just have to hold out until the next release :(
If you ARE running a development version >= r2661 please post the revision number, as well as your OS and Powerpoint versions

With regards to the other issues you're experiencing, they are separate bugs and will need to be reported as such. Be sure to check if there are already bugs matching those descriptions, and when reporting/commenting, be sure to include the version of OpenLP you are having the issue with, as well as your Operating System and Powerpoint versions.
If you are unsure about this, you may be better off asking on the forums or in IRC

Cheers :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers