CSS loading irrational

Reported by Lance Arthur on 2010-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Library
High
Anand Chitipothu

Bug Description

all.css seems to be occasionally loading an incorrect or incomplete version. If you reload the DAISY page or the edit page for any book repeatedly, you'll note that sometimes the font sizes and layout on the DAISY page alter, and the WMB buttons above the textarea on the edit page flip back and forth between correct images and a blank set of <li> tags that have no styles applied.

Lance Arthur (lance-arthur) wrote :

You may need to shift-refresh in your browser to overcome any cached versions of all.css - assuming that the problem really is all.css. Here's a DAISY page to test with:

http://openlibrary.org/books/OL19940093M/golden_notebook./daisy

And an edit page:

http://openlibrary.org/works/OL7492934W/Alice_in_Wonderland/edit

I should add that it isn't these specific pages that exhibit the behavior, it is ANY edit or DAISY page if you reload enough times.

Changed in openlibrary:
assignee: nobody → Anand Chitipothu (anandology)
importance: Undecided → Medium
Lance Arthur (lance-arthur) wrote :

Just want to bump this, hoping it's easily resolved.

Since I am now making changed in production, it's difficult for me to test my changes while the delay exists and make corrections. Additionally, any new classes are not registering so those changes look odd to everyone visiting the pages. Case in point: a new class exists to position a notice to non-admins that deleting records are admin-only. The notice is centered within an existing div and has to be absolutely positioned so no other elements are impacted by its presence. But until the CSS updates, it floats under the buttons and doesn't adopt colors, font sizes and centering.

George (george-archive) on 2010-06-16
Changed in openlibrary:
importance: Medium → High
status: New → Confirmed
milestone: none → general-bucket
milestone: general-bucket → stability
Lance Arthur (lance-arthur) wrote :

I also experienced this switching between versions of templates after updating a macro. I was attempting to switch a button to a link on the edit user page (for interface consistency) and noticed that the changes might show up or might not as I continually refreshed.

George (george-archive) wrote :

Anand - it would be good to hear from you on this - it's been a week since Lance reported it, and it's slowing him down a bit... any input you can provide would be appreciated.

Anand Chitipothu (anandology) wrote :

I'm not sure why that is happening. I added a hook to force-reload all templates, macros, css and js files.

To force-reload, visit:

http://openlibrary.org/admin/reload

Changed in openlibrary:
status: Confirmed → Fix Released
George (george-archive) wrote :

Thanks, Anand. Can you please take a moment to make sure that there are links from the main /admin page to this and any other tools you've built under /admin ? (Otherwise, they'll be forgotten!)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers