Monospace italic font is not monospace in java (regression)

Bug #569396 reported by vilbara on 2010-04-24
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
OpenJDK
New
Undecided
Unassigned
openjdk-6 (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: fontconfig

First noticed in IntelliJ IDEA (java IDE): All italic text in editor is non-monospace in ubuntu 10.04. It has always been monospace in all previous versions of ubuntu.

Can be reproduced in JEdit too:
1. Open/Create any.sh file
2. Type in two lines:
_miii
#miii
3. Go to "Utilities-> Quick Settings -> Edit syntax style of token under caret" and select italic (so comments will be shown italic).

Result: Width of two lines is different, non-monospace font is used.
Expected: Comments are italic but still monospace.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: fontconfig 2.8.0-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic-pae 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic-pae i686
Architecture: i386
Date: Sat Apr 24 13:39:27 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 LC_TIME=de_DE.UTF-8
 LANG=en_US.utf8
 SHELL=/bin/bash
 LC_MEASUREMENT=de_DE.UTF-8
 LC_PAPER=de_DE.UTF-8
SourcePackage: fontconfig

vilbara (vilmantas-baranauskas) wrote :
tags: added: font java regression
vilbara (vilmantas-baranauskas) wrote :

It works fine after now!

(don't know which update and when exactly has fixed it)

alex_sv (avshabanov) wrote :

Latest updates has been installed. Italicized monospace is not monospaced.
This is not a serious bug but quite annoying.

kurt belgrave (trinikrono) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in fontconfig (Ubuntu):
status: New → Invalid
Vitaliy Pomazyonkov (vitorg) wrote :

Reproduced in 10.04 and 8.04 with all updates installed. Not fixed for now.

Changed in fontconfig (Ubuntu):
status: Invalid → Confirmed
Arne Goetje (arnegoetje) wrote :

reassigning, since java does use its own font configuration and not fontconfig.

affects: fontconfig (Ubuntu) → openjdk-6 (Ubuntu)
Vitaliy Pomazyonkov (vitorg) wrote :

Reassigning, since sun-java6 is affected, openjdk-6 is not tested.

affects: openjdk-6 (Ubuntu) → sun-java6 (Ubuntu)
Joel Ebel (jbebel) on 2010-07-07
tags: added: glucid

Confirmed in Netbeans on fresh install of Lucid with OpenJDK. Installing Netbeans installs openjdk-6.

Workaround: I installed ttf-dejavu (which pulls in ttf-dejavu-extra by dependency), and the italic fonts in Netbeans display properly after restarting it.

ledgekindred (dglidden) wrote :

I'm also seeing this problem on 10.04 with all updates applied. It has worked fine in previous versions of Ubuntu.

As a full-time Java developer on linux, I wouldn't classify this as an "annoyance" but as severe. It affects any Java program trying to use monospaced italic fonts. So if you are doing any kind of java UI development, you cannot use Ubuntu 10.04 if you expect it to display correctly.

Matthias Klose (doko) wrote :

confirmed for lucid with openjdk-6. looking at /etc/java-6-openjdk/fontconfig.properties I don't see any obvious problems. But then the config file is for openjdk-6 only and would not explain the issue for sun-java6.

Changed in openjdk-6 (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Matthias Klose (doko) wrote :

The fact that installing ttf-dejavu works around the problem shows that some of the fallback fonts lead to the selection of the non mono font. So there is some fontconfig information wrong (and it shows up with both openjdk-6 and usn-java6).

The other issue is that we should maybe update the fontconfig.properties not to use DejaVu anymore, but the default font (which is?)

Changed in openjdk-6 (Ubuntu Lucid):
status: New → Confirmed
Changed in fontconfig (Ubuntu Lucid):
milestone: none → lucid-updates
Changed in openjdk-6 (Ubuntu Lucid):
milestone: none → lucid-updates
Changed in fontconfig (Ubuntu Maverick):
milestone: none → ubuntu-10.10-beta
Matthias Klose (doko) on 2010-07-14
Changed in openjdk-6 (Ubuntu Maverick):
milestone: none → ubuntu-10.10-beta
Matthias Klose (doko) wrote :

this was caused by moving some font variants from ttf-dejavu-core to ttf-dejavu-extra. For now, just install the ttf-dejavu-extra package.

affects: fontconfig (Ubuntu Maverick) → ttf-dejavu (Ubuntu Maverick)
Matthias Klose (doko) wrote :

openjdk-6-jre will recommend ttf-dejavu-extra for maverick.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-6 - 6b20~pre2-0ubuntu1

---------------
openjdk-6 (6b20~pre2-0ubuntu1) maverick; urgency=high

  * Update from the IcedTea6 trunk.
    - (CVE-2010-2783): IcedTea 'Extended JNLP Services' arbitrary file access.
    - (CVE-2010-2548): IcedTea incomplete property access check for unsigned
      applications
  * openjdk-6-jre: Recommend ttf-dejavu-extra. LP: #569396.
  * Explicitely fail the build on armel. The ARM assembler interpreter is
    disabled and would a 3-5x performance regression compared to the current
    6b18 armel binaries in the archive.
 -- Matthias Klose <email address hidden> Thu, 29 Jul 2010 00:10:53 +0200

Changed in openjdk-6 (Ubuntu Maverick):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-6 - 6b18-1.8.1-0ubuntu1

---------------
openjdk-6 (6b18-1.8.1-0ubuntu1) lucid-security; urgency=high

  * IcedTea6 1.8.1 release.
    - Fix security flaw in NetX that allows arbitrary unsigned apps to set
      any java property.
    - Fix security flaw in NetX that allows unsigned code to access any file
      on the machine (accessible to the user) and write to it.
  * openjdk-6-jre: Recommend ttf-dejavu-extra. LP: #569396.
  * Don't build the plugin on sparc for hardy and jaunty releases.

openjdk-6 (6b18-1.8-4ubuntu3) lucid-proposed; urgency=low

  * Update from the 1.8 branch.
  * Rebuild with fixed ant.
  * Disable building the shark based VM on armel.
  * Always build the ARM assembler interpreter in arm mode.

openjdk-6 (6b18-1.8-4) unstable; urgency=low

  * Update from the 1.8 branch.
    - Plugin and netx fixes.
    - Don't link the plugin against the libxul libraries. Closes: #576361.
    - More plugin cpu usage fixes. Closes: #584335, #587049.
    - Plugin: fixes AppletContext.getApplets().
    - Fix race conditions in plugin initialization code that were causing
      hangs when loading multiple applets in parallel.
  * Fix Vcs-Bzr location. Closes: #530883.
  * Search for unversioned llvm-config tool.
  * Don't set XFILESEARCHPATH and NLSPATH on startup. LP: #586641.
  * Fix chinese font metrics and prefer using 'WenQuanYi Micro Hei' font.
    LP: #472845.
  * Strip libjvm.so with --strip-debug instead of --strip-unneeded.
    LP: #574997.
  * Don't turn on the ARM assembler interpreter when building the shark
    VM.

openjdk-6 (6b18-1.8-3) unstable; urgency=low

  * Update from the 1.8 branch.
    - Plugin fixes. LP: #597714.
  * Add powerpcspe build fixes (Sebastian Andrzej Siewior). Closes: #586359.
  * Work around build failure on buildds configured with low ARG_MAX
    (Giovanni Mascellani). Closes: #575254.
 -- Matthias Klose <email address hidden> Mon, 26 Jul 2010 23:39:23 +0200

Changed in openjdk-6 (Ubuntu Lucid):
status: Confirmed → Fix Released
Changed in ttf-dejavu (Ubuntu Lucid):
status: New → Invalid
Changed in ttf-dejavu (Ubuntu Maverick):
status: New → Invalid
Robbie Williamson (robbiew) wrote :

Do we know this bug exists with sun-java or is that speculation. Just trying to get the accurate status on the bug, thanks. :)

Yes, this affects sun java as well.

ls -l /etc/alternatives/java
/etc/alternatives/java -> /usr/lib/jvm/java-6-sun/jre/bin/java

java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Server VM (build 16.3-b01, mixed mode)

Italic font is not monospace after removing ttf-dejavu and ttf-dejavu-extra.

Sergey Savchuk (rifcoder) wrote :

Actually, i've tested OpenJDK 6b22-1.10.2-0ubuntu1~11.04.1 and java-6-sun-1.6.0.26 for this issue, but both suffer from it. Italic bold font looks ugly, so i don't think it was solved.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sun-java6 (Ubuntu Lucid):
status: New → Confirmed
Dac Chartrand (conner-bw) wrote :

I had this problem with Netbeans and 10.04 LTS. Solved by doing.

$ sudo apt-get install ttf-dejavu-extra

Regards,

Adolfo Jayme (fitojb) on 2013-05-17
no longer affects: sun-java6 (Ubuntu)
no longer affects: sun-java6 (Ubuntu Lucid)
no longer affects: sun-java6 (Ubuntu Maverick)
no longer affects: ttf-dejavu (Ubuntu)
no longer affects: ttf-dejavu (Ubuntu Lucid)
no longer affects: ttf-dejavu (Ubuntu Maverick)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers