_tkinter.TclError: unknown color name "{#c3c3c3}"

Bug #371720 reported by Steve Hammond on 2009-05-04
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
OpenIPMI
New
Undecided
Unassigned
Tix
New
Undecided
Unassigned
tix (Ubuntu)
Medium
Georges Khaznadar
Nominated for Jaunty by GS
Nominated for Karmic by Matt Joiner

Bug Description

I have a python program which uses widgets from tkinter-tix. It worked fine before the upgrade and still works fine on non-upgraded systems both windows and linux ie. only ubuntu 9.04 do I have this problem. I get the following error report when I try to run it...

 Traceback (most recent call last):
  File "./bozodb4.py", line 124, in <module>
    vp_start_gui()
  File "./bozodb4.py", line 37, in vp_start_gui
    w = Bozo_Data_Base (root)
  File "./bozodb4.py", line 67, in __init__
    self.tix26 = Tix.FileSelectBox(master, pattern="*.bdb", command=self.file_pick) #pattern sets the pattern for the filter box
  File "/usr/lib/python2.6/lib-tk/Tix.py", line 794, in __init__
    TixWidget.__init__(self, master, 'tixFileSelectBox', ['options'], cnf, kw)
  File "/usr/lib/python2.6/lib-tk/Tix.py", line 307, in __init__
    self.tk.call(widgetName, self._w, *extra)
_tkinter.TclError: unknown color name "{#c3c3c3}"

affects: ubuntu → python2.6 (Ubuntu)
Krzysztof Klimonda (kklimonda) wrote :

http://bugs.python.org/issue3872 - I'm pasting link to upstream bts report as I can't add it in normal way. According to them it was fixed in 2.6.2c1 but test_combotix.py still throws exception for me.

Changed in python2.6 (Ubuntu):
status: New → Confirmed
summary: - python-tkinter-tix program has unknown color error
+ _tkinter.TclError: unknown color name "{#c3c3c3}"
Krzysztof Klimonda (kklimonda) wrote :

It seems to be related to the version of tix library we ship.
The most recent is 8.4.3 but for some reson we still ship 8.4.0.
I have compiled 8.4.3 from source and after some more work text_combotix.py has worked.

Thanks for the response. I haven't tried to get/recompile the new library yet but will do it soon.

> Date: Tue, 12 May 2009 17:59:30 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 371720] Re: _tkinter.TclError: unknown color name "{#c3c3c3}"
>
> It seems to be related to the version of tix library we ship.
> The most recent is 8.4.3 but for some reson we still ship 8.4.0.
> I have compiled 8.4.3 from source and after some more work text_combotix.py has worked.
>
> --
> _tkinter.TclError: unknown color name "{#c3c3c3}"
> https://bugs.launchpad.net/bugs/371720
> You received this bug notification because you are a direct subscriber
> of the bug.

_________________________________________________________________
Hotmail® has ever-growing storage! Don’t worry about storage limits.
http://windowslive.com/Tutorial/Hotmail/Storage?ocid=TXT_TAGLM_WL_HM_Tutorial_Storage1_052009

affects: python2.6 (Ubuntu) → tix (Ubuntu)
C de-Avillez (hggdh2) on 2009-05-14
Changed in tix (Ubuntu):
importance: Undecided → Medium
Silvano (silvavlis) wrote :

I can confirm the bug and that the solution (compiling and installing version 8.4.3) works.

Changed in tix:
status: Unknown → Fix Released
Changed in tix:
importance: Unknown → Undecided
status: Fix Released → New
Hungerburg (pch-myzel) wrote :

This bug is still present in ubuntu 10.4, relevant package is: tix_8.4.0-7ubuntu1_amd64.deb.

Hungerburg (pch-myzel) wrote :

An updated and working tix package is available here:
# https://launchpad.net/~portis25/+archive/ppa/+build/1416208
After installation, I had to fix an error in library location:
# ln -s /usr/lib/libTix8.4.so.1 /usr/lib/Tix8.4.3/libTix8.4.so.1
--
peter

cminyard (minyard) wrote :

Adding a dsc file and a diff file to build 8.4.3. Can we please get this fixed? The fix has been available for a very long time.

cminyard (minyard) wrote :

The diff file, you'll need this and the dsc file, along with the original source named tix_8.4.3.orig.tar.gz to build the package.

Lone Ranger (lone.ranger) wrote :

I have 10.04 (32 bits), how can I fix this? The attached working version is for 64 bits. I can't use pyfaces program because of this bug.

Marcos (devilcius) wrote :

i've downloaded the .deb from https://launchpad.net/ubuntu/maverick/i386/tix/8.4.3-4 and it worked (ubuntu 9.10)

HamilJF (john-hamilton) wrote :

Just discovered this myself, using python and ix for the first time. I've got an AMD64 machine and 10.04, and no idea how to convert the stuff referenced here into a usable build. Is there a 64bit .deb somewhere ? Is there a workaround by specifying colour(s) in the instantiation ?

tags: added: patch
Steve Hammond (st-hammond) wrote :

This seems to be an ubuntu problem, not a problem with other distros. Some people have gotten around it by getting the source code an recompiling.

> Date: Sat, 13 Nov 2010 23:02:58 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 371720] Re: _tkinter.TclError: unknown color name "{#c3c3c3}"
>
> Just discovered this myself, using python and ix for the first time.
> I've got an AMD64 machine and 10.04, and no idea how to convert the
> stuff referenced here into a usable build. Is there a 64bit .deb
> somewhere ? Is there a workaround by specifying colour(s) in the
> instantiation ?
>
> --
> _tkinter.TclError: unknown color name "{#c3c3c3}"
> https://bugs.launchpad.net/bugs/371720
> You received this bug notification because you are a direct subscriber
> of the bug.

Georges Khaznadar (georgesk) wrote :

The release 8.4.3-8, published in debian/experimental, has the bug fixed.

Changed in tix (Ubuntu):
assignee: nobody → Georges Khaznadar (georgesk)
status: Confirmed → Fix Committed
Changed in tix (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.