xml-rpc error code must be an int and not a string

Bug #257581 reported by Laurent Lauden on 2008-08-13
74
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Odoo Server (MOVED TO GITHUB)
Fix Released
Wishlist
OpenERP's Framework R&D
OpenERP
Status tracked in Trunk
Declined for 4.2 by Christophe Simonis (OpenERP)
Trunk
Fix Released
Undecided
Unassigned

Bug Description

at www.xmlrpc.com :

"The <methodResponse> could also contain a <fault> which contains a <value> which is a <struct> containing two elements, one named <faultCode>, an <int> and one named <faultString>, a <string>."

Tiny Erp return a string and not an int. It's not very clear on the xmlrpc website but for exemple the apache java xmlrpc client understand only integers

Related branches

Fabien (Open ERP) (fp-tinyerp) wrote :

Planned for Open ERP v6.

Changed in openerp:
status: New → Won't Fix
Fabien (Open ERP) (fp-tinyerp) wrote :

Planned for v6.

Changed in openobject-server:
status: New → Won't Fix

Fabien,

I think we would really need that at Smile for our largest project.

you said it's planned for v6. Why? Is that because you don't have resources to do it or because it would break some backward compatibility critically?

If that's only a lack of resource, please do tell us because we might be ready to implement it, waiting the next version for one year is hardly and option and the workarounds are hugly for us.

Finally, you said it's planned for v6. But if you smply flag the bug as "won't fix", their is no clue it's planned for v6, so IMHO we should flag that in a different way (re-target it?) because else the risk it high that it get forgotten or that somebody looking for it have trouble finding that the bug is known (so he will win time, possibly fixing the bug instead of just asking himself if he is right or not).

Claimed to be fixed in Activity Solutions branch ( see https://code.launchpad.net/~activity/openobject-server/trunk ), revision #1256, Revision ID: <email address hidden>
see commit: http://bazaar.launchpad.net/~activity/openobject-server/trunk/revision/1256

If this proves to be right, I suggest merging that to OpenERP server trunk at least.

Hope this helps,

Raphaël Valyi

Shah Japan (jsh.axelor) wrote :

Yes Its very irritating when working with heterogeneous environment, that we won't get the FaultCode and FaultString.

I'm using the attached patch till OpenERP doesn't support it, may be this can help out someone.

This patch will not affect any of OpenERP client as it checks for the UserAgent before raising the Exception.

Changed in openobject-server:
status: Won't Fix → Confirmed
importance: Undecided → Low
Changed in openobject-server:
importance: Low → Medium
Yan-PCSol (yannick-soldati) wrote :

+1

Yan-PCSol (yannick-soldati) wrote :

need to be corrected ASAP, breaks compatibilty with third parties and the XML-RPC standard

+1, major annoyance for integrating with Java app.

Changed in openobject-server:
importance: Medium → High
milestone: none → 6.0

Keeping this as wishlist for post v6 + updated importance according to guidelines

Changed in openobject-server:
importance: High → Wishlist
milestone: 6.0 → none
assignee: nobody → OpenERP's Framework R&D (openerp-dev-framework)

All right, at least it's good we keep it in the radar indeed.

On Tue, Nov 23, 2010 at 8:22 PM, Olivier Dony (OpenERP) <
<email address hidden>> wrote:

> Keeping this as wishlist for post v6 + updated importance according to
> guidelines
>
> ** Changed in: openobject-server
> Importance: High => Wishlist
>
> ** Changed in: openobject-server
> Milestone: 6.0 => None
>
> ** Changed in: openobject-server
> Assignee: (unassigned) => OpenERP's Framework R&D
> (openerp-dev-framework)
>
> --
> xml-rpc error code must be an int and not a string
> https://bugs.launchpad.net/bugs/257581
> You received this bug notification because you are subscribed to
> OpenObject Server.
>
> Status in OpenERP Installer: Won't Fix
> Status in OpenERP trunk series: Won't Fix
> Status in OpenObject Server: Confirmed
>
> Bug description:
> at www.xmlrpc.com :
>
> "The <methodResponse> could also contain a <fault> which contains a <value>
> which is a <struct> containing two elements, one named <faultCode>, an <int>
> and one named <faultString>, a <string>."
>
> Tiny Erp return a string and not an int. It's not very clear on the xmlrpc
> website but for exemple the apache java xmlrpc client understand only
> integers
>
>
>

Yan-PCSol (yannick-soldati) wrote :

It is totally stupid to put that in the wishlist because it doesn't respect the XML-RPC standards. Please do it for version 6 because I always need to patch the server for integration with Java applications.

On Wednesday 24 November 2010, you wrote:
> It is totally stupid to put that in the wishlist because it doesn't
> respect the XML-RPC standards. Please do it for version 6 because I
> always need to patch the server for integration with Java applications.

Please read before writing.

I have provided, months ago, a good explanation why this behavior CANNOT
change.
Don't keep posting the same question, it has been answered.

--
Say NO to spam and viruses. Stop using Microsoft Windows!

Yan-PCSol (yannick-soldati) wrote :

> Please read before writing.
>
> I have provided, months ago, a good explanation why this behavior CANNOT
> change.
> Don't keep posting the same question, it has been answered.

I don't see your explanation in this bug. Where is it?

vsuarez (vsuarez) wrote :

> I don't see your explanation in this bug. Where is it?

Nor do I. I think this explanation is worth a read (we are facing serious
problems integrating OpenERP in a heterogeneous environment)

Yan-PCSol (yannick-soldati) wrote :

I'm still waiting... Where is your explanation? I want to understand why it is now in the wishlist!

I'm currently implementing an Android application and I just can't use Java XMLRPC libraries because of if this bug.

fix landed in lp:openobject-server 3669 revid:<email address hidden>

Changed in openobject-server:
status: Confirmed → Fix Released
Changed in openerp:
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers