Error on sale order in 6.1 with demo data installed

Bug #1008519 reported by Paul Catinean
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Odoo Web (MOVED TO GITHUB)
Status tracked in Trunk
6.1
Confirmed
Low
OpenERP Publisher's Warranty Team
Trunk
Invalid
Low
OpenERP Publisher's Warranty Team

Bug Description

I have installed openerp verion 6.1, a recent nightly (max 7 nightly builds ago from this day) and when i check out the graph view of the sale orders with the demo data installed then click Maxtor and then the back button i get this error:

Your version of OpenERP is unsupported. Support & maintenance services are available here: OpenERP Entreprise.

QWeb2 - template['ViewManagerDebug']: Runtime Error: TypeError: dict.view.fields_view is undefined

http://localhost:8069/web/webclient/js:18953

If there is any need for further information please let me know,

Thank you!

Revision history for this message
Amit Bhavsar (Open ERP) (amb-openerp) wrote :

Hello,

I have checked your scenario with following revision,
Server : 4194
web : 2337
addons : 6829.
But at my end working fine. That's why I have attached the video. would you please check it.

So would you please try with latest revision and notify us where you have faced the problem.

Thank you and waiting for your reply!

Changed in openerp-web:
status: New → Incomplete
Revision history for this message
Serpent Consulting Services (serpent-consulting-services) wrote :

Hello wiz,

Did you use windows ? I remember I had seen this once, but as soon as I restart the server with web and cleared the cache, it disappeared!

Thanks.

Revision history for this message
Amit Bhavsar (Open ERP) (amb-openerp) wrote :
Changed in openerp-web:
status: Incomplete → Confirmed
importance: Undecided → Low
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)
Revision history for this message
Richard Lewis (richard-lewis-r) wrote :

I'm seeing this error. In my case, I'm trying to override openerp.web.ListView.start. Doing so causes this error. Removing my overriden start method prevents the error. Even if all the overriden start method does is call the super start method, the error occurs.

Platform in this case is Firefox 10 on Linux. Interestingly, using the same database with Chrome causes another QWeb-reported error, not entirely unrelated:

Uncaught Error: QWeb2 - template['ViewManagerDebug']: Runtime Error: TypeError: Cannot read property 'view_id' of undefined

What is ViewManagerDebug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers