[6.1]auto create 2 address record when i save the partner

Bug #980529 reported by jerryzhang
56
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Odoo Web (MOVED TO GITHUB)
Status tracked in Trunk
6.1
Fix Committed
Low
OpenERP Publisher's Warranty Team
Trunk
Invalid
Low
OpenERP Publisher's Warranty Team
OpenERP Community Backports (Web)
New
Undecided
Unassigned
6.1
New
Undecided
Unassigned

Bug Description

res.partner module, Partner Views, when I create a new partner, only input partner name and save, then on the address tab, I find the address number change to 2, if change to tree view, can find two empty record in the tree view. This problem will appear little.
But when I modify the res.partner, code as follow, then this bug will appear very frequent. pls help confirm if this is a bug or my mistake.thanks

class res_partner(osv.osv):
    _name = "res.partner"
    _inherit = 'res.partner'
    _columns = {
        'partner_level': fields.many2one('res.partner.level','Partner Level'),
   }
res_partner()

<record id="view_partner_form_extend" model="ir.ui.view">
            <field name="name">res.partner.form.extend</field>
            <field name="model">res.partner</field>
            <field name="type">form</field>
            <field name="inherit_id" ref="base.view_partner_form"/>
            <field name="arch" type="xml">
            <xpath expr="/form/notebook/page[@string='General']" position="before">
                <page string="Info">
                    <field colspan="2" name="partner_level" widget="selection"/>
                </page>
            </xpath>
            </field>
 </record>

Tags: maintenance

Related branches

affects: openobject-server → openerp-web
Changed in openerp-web:
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Mohammed Shekha(Open ERP) (msh-openerp) wrote :

Hello,

The issue has been commited in lp:~openerp-dev/openerp-web/6.1-opw-572829-msh.

It will be merged soon in stable version 6.1.

Thanks.

tags: added: maintenance
Changed in openerp-web:
status: Confirmed → Fix Committed
Revision history for this message
Fabien (Open ERP) (fp-tinyerp) wrote :

fixed in trunk.

affects: openerp-web → openobject-server
Amit Parik (amit-parik)
summary: - auto create 2 address record when i save the partner
+ [6.1]auto create 2 address record when i save the partner
Revision history for this message
Yaiza Bailen (ybailen) wrote :

Hi!

The application of the patch for 6.1 that Mohammed posted makes that a record with a o2m field (in form mode in the view) is only displayed if there is data in that o2m field. If not, the view is shown as empty.

http://ubuntuone.com/67uLIUAXf5GlBjySZWthBP

If you save the o2m field with data, then the record is displayed correctly.

Without this patch it creates two empty records (see video below):

http://ubuntuone.com/3R30n5Nrsyvvoy20jmSUQt

Version 6.1
web: revno 2389
server: revno 4227
addons: revno 6869
extra-addons: revno 5773

Thanks,
Yaiza

Revision history for this message
Serpent Consulting Services (serpent-consulting-services) wrote :

As this bug has already got some recent duplicates, hope to get this bug a life!

Thanks.

affects: openobject-server → openerp-web
Revision history for this message
Mohammed Shekha(Open ERP) (msh-openerp) wrote :

Hello,

The fix has been landed in lp:~openerp-dev/openerp-web/6.1-opw-572829-msh with revision 2458.

As soon as fix has been approved it will be merged in stable version 6.1

Thanks.

Revision history for this message
Yaiza Bailen (ybailen) wrote :

Hi Mohhamed,

Can you please look at the comment #3 I posted some time ago? That patch solves that issue but creates a different one.

Thanks,
Yaiza

Revision history for this message
Mariano Ruiz (marianoruiz) wrote :

The error persist in the latest #2512. Applying the patch provided by msh-openerp solve my problem. Thanks Mohammed !

Revision history for this message
Maik Steinfeld (m-steinfeld-k) wrote :

Problem still persist:

server (4352)
addons (7219)
web (2513)

Revision history for this message
Réal Carbonneau (real-carbonneau) wrote :

Why is the merge of this being rejected with reason "Abstain"? I have just tested it and it correctly solves the problem with any noticeable regressions yet.

Revision history for this message
Maik Steinfeld (m-steinfeld-k) wrote :

We have still the problem, also with the bugfix, which is approved.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers