[6.1.1] Mandatory field stay red after invalid selection

Bug #918190 reported by Yann Papouin on 2012-01-18
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Odoo Web (MOVED TO GITHUB)
Status tracked in Trunk
6.1
Fix Committed
Low
OpenERP Publisher's Warranty Team
Trunk
Invalid
Low
Unassigned

Bug Description

This error occurred in every mandatory combo box

Steps to reproduce:

- New database with demonstration data
- Logged as "admin"
- Edit user preferences
- In language combo box select the empty line
  > Field becomes red
- Return to English

Result:
- Field stay red

Expected:
- Field return to "light fushia"

Related branches

Hello Yann Papouin,

Thanks for looking It.

Yes, I am agree with you regarding Field should be return to "light fushia".
For now It needed changes regarding the improvement what you suggested in bug specification.
So I am setting It as wishlist.

Thanks.

Changed in openerp-web:
assignee: nobody → OpenERP R&D Web Team (openerp-dev-web)
importance: Undecided → Wishlist
status: New → Confirmed
Vaibhav Darji (vaibhav-openerp) wrote :

Hello Yann Papouin,

Should be fix commited in https://code.launchpad.net/~openerp-dev/openerp-web/trunk-bug-918190-vda
at revID: <email address hidden>

summary: - [6.1.rc1] Mandatory field stay red after invalid selection
+ [6.1.1] Mandatory field stay red after invalid selection
Yann Papouin (yann-papouin) wrote :

Since it was a wrong implementation, the importance should be set to low instead of wishlist and this fix should land in the 6.1 branch.

Amit Parik (amit-parik) on 2012-06-07
Changed in openerp-web:
assignee: OpenERP R&D Web Team (openerp-dev-web) → OpenERP Publisher's Warranty Team (openerp-opw)
importance: Wishlist → Low

Hello.

This bug seems to be solved now.

Changed in openerp-web:
status: Confirmed → Invalid

Oups, sorry, I haven't seen the 6.1 tag.

Thanks a lot for reporting this bug and contributing to OpenERP. We have double-checked this issue and we can confirm that it does not affect the latest development version of OpenERP (trunk), but only a stable version.
The official OpenERP bug management policy states that bugs reported on stable branches follow a much stricter qualification process, to limit the risk of regressions on these production-grade versions.
These are exclusively handled by the OpenERP Entreprise Team, and should be reported via the OpenERP Enterprise (OPW) maintenance service.
You can find more details about all of this in the FAQ of our Bug Management Policy documentation:
   http://bit.ly/openerp-bugs-faq (FAQ #2)

Thank you for your contributions and for your understanding!

Changed in openerp-web:
status: Invalid → Won't Fix
Yann Papouin (yann-papouin) wrote :

I am sickened by your bug management policy ... I reported this one month before the final release.
So now I just have to stop reporting 6.1 bugs and fix them myself and keep the solution for me ?

Ferdinand (office-chricar) wrote :

the only way to get rid of the red filed is to open another form

Changed in openerp-web:
status: Won't Fix → New
tags: added: maintenance
Changed in openerp-web:
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers