[Trunk/7.0] Company logo not shown if database name contains capitals

Bug #1172679 reported by Karel Marissens on 2013-04-25
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Odoo Web (MOVED TO GITHUB)
Status tracked in Trunk
7.0
Fix Released
Low
OpenERP Publisher's Warranty Team
Trunk
Confirmed
Low
OpenERP R&D Web Team

Bug Description

Steps to reproduce:
- Create a new database, with a capital in the name.
- Add an image for your company.

Observed result:
- Company logo (top left) is still the OpenERP logo.

Expected result:
- The image added for the company.

OpenERP version:
- 7.0-20130424-232422

Origin of the problem:
In controllers/main.py, a '.lower()' is executed on the dbname when creating a registry, resulting in an exception since the lowercase database doesn't exist:
registry = openerp.modules.registry.Registry(dbname.lower())

Related branches

summary: - Company logo not shown if database name contains capitals
+ [Trunk/7.0] Company logo not shown if database name contains capitals
Changed in openerp-web:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → OpenERP R&D Web Team (openerp-dev-web)
tags: added: maintenance

Hi Karel Marissens,

Thanks for pointing the issue and the root cause, for V7.0, this issue has been fixed in the,
Branch: lp:~openerp-dev/openerp-web/7.0-opw-592257-rgo
Rev Id: <email address hidden>
Rev #: 3918

This fix will soon be reviewed and merged with main stable branch.

Vincent Gerris (vgerris) wrote :

Thanks for the fix.
Can you give a link to that stable branch?
It is a bit unclear where I can find it to use that code.
I use nightly now.

Hi Vincent,

The branch is under review of our experts, once it gets approved, it will be merged with main stable branch. This fix should be available in the nightly build that is going to generated on the day after it gets merged with main stable branch.

For now, if you want to use this patch for your windows version, you need to manually apply the changes at your end in main.py file(you should find it under <openerp installation directory>/server/server/openerp/addons/web/controller/)

These are the changes you need to apply, http://bazaar.launchpad.net/~openerp-dev/openerp-web/7.0-opw-592257-rgo/revision/3918.

After applying the changes, you need to restart the OpenERP service(you can find it from control panel/administration tools/services) for patch to take the effect.

Hope this helps.

Thanks.

Vincent Gerris (vgerris) wrote :

Hi Ravi,

Thank you for the reply.
I do not run Windows, only Linux.
Currently on both Ubuntu en CentOS.
It is still unclear to me what the stable branch is.
I understand that the nightly branch is built from it, so I will update from there.
I use http://nightly.openerp.com/ and then click 7.0 LTS.
I was a bit surprised to only see nightly, not stable.
Thanks for the explanation.

Hi Vincent,

We have an automated process of building the packages(like, .deb, .exe, .rpm etc.) of latest OpenERP source code from the main stable branches(like, lp:openobject-addons/7.0, lp:openerp-web/7.0) and these packages are put on http://nightly.openerp.com.

The branch, lp:~openerp-dev/openerp-web/7.0-opw-592257-rgo is a stacked branch which will soon be integrated with the main stable branch, lp:openerp-web/7.0. The package that is going to be generated after the integration date will have this issue solved. Until the branch gets merged, you can use the fix mentioned in comment#3 at your end by manually applying it to your your code.

Hope this helps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers