[6.1] [list] drag and drop reordering: allow reordering but does not save it in page view

Bug #1010400 reported by Guewen Baconnier @ Camptocamp on 2012-06-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Odoo Web (MOVED TO GITHUB)
Status tracked in Trunk
6.1
Confirmed
Low
OpenERP Publisher's Warranty Team
Trunk
Invalid
Undecided
Unassigned

Bug Description

Hello,

Here is an issue I could just reproduce on runbot, with the 6.1 version.

Context:
I'm on a page view, which contains a one2many field with a sequence.

Actual :
I can drag & drop the lines of the one2many field in order to change the order of the lines.
The line I moved stay where I dropped it and the sequence numbers are updated on the view in order to reflect the new positions of the lines.
When I leave or refresh the page, the positions are reset to their original position.
This is really confusing because you are able to modify something and so you think that it will update the data (as when you move an item on a kanban view)

Expected:
Solution 1: each time I move a line, the new positions are saved
Solution 2: I should not be able to drag & drop the lines on the page view

To reproduce:
 - On runbot.openerp.com, I open a product
 - I go to the Suppliers tab
 - If it has no or one supplier only, I edit the product to add some
 - I save it so I'm on the page view again
 - I drag & drop the lines to reorder them -> sequence numbers are updated on my screen and lines are moved
 - I refresh the page -> sequence numbers reset

Best Regards
Guewen

Related branches

Changed in openerp-web:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → OpenERP R&D Web Team (openerp-dev-web)
Fabien (Open ERP) (fp-tinyerp) wrote :

We have a task to review the dr&g&drop feature, so I drop this bug.

Changed in openerp-web:
status: Confirmed → Invalid
Changed in openerp-web:
status: Invalid → Confirmed

This o2m and m2m where modified in 2567 to set the 'reorderable' flag to false. But this flag needs to be handled correctly by the list view.

summary: - drag and drop reordering: allow reordering but does not save it in page
- view
+ [list] drag and drop reordering: allow reordering but does not save it
+ in page view

Hello,

I have checked in detail as description, I think this issue is only for 6.1 and not for trunk.

So, request to bug qualifying team for assign this bug to responsible team.

Thanks.

Hello Folks,

Now It's effect to 6.1 only . That's why I am reassign to OPW team.

Thanks

Changed in openerp-web:
assignee: OpenERP R&D Web Team (openerp-dev-web) → OpenERP Publisher's Warranty Team (openerp-opw)
Amit Parik (amit-parik) wrote :

Hello,

This problem is still persist on trunk, That's why I am reassigning the respective team.

I have attached the video for it, which will more clear this things.

Thank You!

Amit Parik (amit-parik) wrote :
Changed in openerp-web:
assignee: OpenERP Publisher's Warranty Team (openerp-opw) → OpenERP R&D Web Team (openerp-dev-web)
Jiten (OpenERP) (jiten-openerp) wrote :

Hello Amit,

It's working fine as expected in trunk.

If you change sequence from page view and than you do any other action like,
- if you click on any other menu than message pop up for discard this last changes and not stored in system.
- but if you click on direct refresh button of browser than its automatic discarded changes because in this case, save action is not fired after did changes so its not stored in system.

But you do same thing with editable view and save it than sure it will be store and see changes in sequence.

Please refer a video that i attached uder.

Changed in openerp-web:
status: Confirmed → Invalid

Hello,

Your dance around the status and assignee is fun, really.
Yet, the issue is still there in the 6.1 version, and users make errors due to this bug.
So I will report this bug on the OPW contract, thereby I add my dance step.

Thanks
Guewen

Changed in openerp-web:
assignee: OpenERP R&D Web Team (openerp-dev-web) → OpenERP Publisher's Warranty Team (openerp-opw)
status: Invalid → New
tags: added: maintenance

Hello,

It has been fixed in lp:~openerp-dev/openerp-web/6.1-opw-579115-msh.

This branch will remove the feature of drag and drop if you are in page view, as page view is readonly mode.

Thanks.

Changed in openerp-web:
status: New → Fix Committed
Yann Papouin (yann-papouin) wrote :

Should be released in 6.1 branch

Hello Folks,

This Issue Occurs in latest Trunk and 7.0. That's why I am reopning this Issue again.

Thanks!

summary: - [list] drag and drop reordering: allow reordering but does not save it
- in page view
+ [Trunk/7.0] [list] drag and drop reordering: allow reordering but does
+ not save it in page view
summary: - [Trunk/7.0] [list] drag and drop reordering: allow reordering but does
- not save it in page view
+ [Trunk/7.0/6.1] [list] drag and drop reordering: allow reordering but
+ does not save it in page view

Hello Folks,

Sorry for the Inconvenience. It's no more effect to trunk and 7.0. That's why I am closing this Issue for trunk and 7.0.

Thanks!

Hello,

this bug has not been fixed on 6.1: if we reorder the lines and we save it, the order will not be taken into account, it will be reset to the original order.

See what is stated in the bug description:
"Expected:
Solution 1: each time I move a line, the new positions are saved"

Please have a look at it.

Thanks.

summary: - [Trunk/7.0/6.1] [list] drag and drop reordering: allow reordering but
- does not save it in page view
+ [6.1] [list] drag and drop reordering: allow reordering but does not
+ save it in page view
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers