[embed] onchange trigger don't work in embedded read-write mode

Bug #1009925 reported by Fabian Semal on 2012-06-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Web (MOVED TO GITHUB)
Status tracked in Trunk
6.1
Confirmed
Low
OpenERP Publisher's Warranty Team
Trunk
Invalid
Low
Unassigned

Bug Description

Hello,

In any shared view exported with the share module, the onchange doesn't work. For example, if you export the sale order view, changing the partner does not change the addresses.

Regards,

Fabian

tested on last revisions as for the 2012-06-07
Under OPW : M120516582-orocbsbs

Related branches

Amit Parik (amit-parik) wrote :

Hello Fabian Semal,

I have checked this issue, due to access error I am not able to open any shared view. Which is already reported on lp:1005404 and lp:1004833. You specified a different error.

I have attached a video for more reference, So would you please check it and notify us or may I missed something.

Thanks and waiting for your reply!

Amit Parik (amit-parik) wrote :
Changed in openobject-addons:
status: New → Incomplete
Fabian Semal (fabian.semal) wrote :

Hello Amit Parik,

Except for the onchange, the module works quite fine but you have to use another user then the one generated and change it in the html file where you copy/paste the generated code (see example). You can test with the admin user, so you'll be sure to have all rights to object. It's also necessary to add the class="openerp" in the body tag.

Here is an example :

<html>
<body class="openerp">
<script type="text/javascript" src="http://localhost:8069/web/webclient/js"></script>
<script type="text/javascript">
 new openerp.init(["web"]).web.embed("http://localhost:8069", "testdb", "admin", "adminpwd",564, {
 "display_title": false,
 "search_view": true
});
</script>
</body>
</html>

Regards,

Fabian

Hello,

I just replied to this issue on launchpad but I should also mention that
those bugs (and a few other concerning the share module) have been fixed
last week by odo and chs during the OpenERP training day. As it was was
not working properly during the training they fixed it directly.

About the onchange doesn't working, it's in the embeded code, if you
test in OpenERP like in the video you posted, it's just a normal view in
openerp so onchange works like usual.

Let me know if you need more information.

Regards,

Fabian

On 06/07/2012 01:07 PM, Amit Parik (OpenERP) wrote:
> Hello Fabian Semal,
>
> I have checked this issue, due to access error I am not able to open any
> shared view. Which is already reported on lp:1005404 and lp:1004833. You
> specified a different error.
>
> I have attached a video for more reference, So would you please check it
> and notify us or may I missed something.
>
> Thanks and waiting for your reply!
>

I can confirm this, on_change triggers do not seem to be called on embedded forms created with read-write access.

Note that this has a low impact because the read-write mode is not meant to allow creation of records, but only edition -> on_change calls are less necessary for small edits. Still, this is a real bug.

Changed in openobject-addons:
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)
importance: Undecided → Low
status: Incomplete → Confirmed
summary: - share : onchange doesn't work
+ onchange trigger don't work in embedded read-write mode
tags: added: maintenance
tags: removed: onchange share
affects: openobject-addons → openerp-web

I would like to correct it, but the share module is currently broken in trunk...

summary: - onchange trigger don't work in embedded read-write mode
+ [embed] onchange trigger don't work in embedded read-write mode

Salut,

Pas la peine, le support l'a fixé :
lp:~openerp-dev/openerp-web/6.1-opw-575643-cpa

Mais je crois qu'ils manquent de communication pour suivre ce qui est
fixé ou pas ;-)

Mais merci quand même,

Fabian

On 06/25/2012 03:23 PM, Nicolas Vanhoren (OpenERP) wrote:
> ** Summary changed:
>
> - onchange trigger don't work in embedded read-write mode
> + [embed] onchange trigger don't work in embedded read-write mode
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments