State information for partners not mapped correctly (fix attached)

Bug #1183837 reported by Brendan Clune (Logic Supply) on 2013-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenERP Connector - Magento
Undecided
Guewen Baconnier @ Camptocamp

Bug Description

Apologies for not creating a separate branch/merge proposal; I'm not extremely familiar with Launchpad permissions and didn't want to accidentally upload the code publicly!

The connector currently expects information about the partner's state to come from a 'state' field in the API call, when it in fact comes from the 'region' field. This patch simply changes 'state' to 'region' in the two occurrences where it is required.

If this breaks backwards (or forwards) compatibility with Magento, please let me know. (It works for 1.7.0.2.)

Thanks,
Brendan

Changed in openerp-connector:
status: New → Confirmed
assignee: nobody → Guewen Baconnier @ Camptocamp (gbaconnier-c2c)

Hi Brendan,

No worries about the branch, I'm already pleased to see your bug report and patch.

For a next time, you can just push a branch on :

lp:~brendan-clune/openerp-connector/name-of-your-branch

The permissions will be correct because they depend on the project (second part of the url).

Your patch is correct, I checked in the old mappings and the field is called 'region' whatever was the Magento version. I'll merge it right now.

Thanks,
Guewen

Changed in openerp-connector:
status: Confirmed → Fix Released
information type: Embargoed → Public
affects: openerp-connector → openerp-connector-magento
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers