Residual Amount Show Double Amount of Invoice Amount

Bug #775398 reported by sja on 2011-05-02

This bug report was converted into a question: question #166003: Residual Amount Show Double Amount of Invoice Amount.

92
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Invalid
Undecided
Unassigned
OpenERP Colombia
Undecided
Unassigned

Bug Description

Hello,
I have updated bzr version (server-3415, addons-4552) for openerp_6,
I have purchase one machine and want to create invoice in openerp_6, but when i create invoice line with account of Fixed Assets with internal type (except regular) and than i go for valid invoice that time system give me Double amount of Invoice in Residual.
I think this problem may arise with fixed coding on internal type, due to double amount in residual all accounting entries are going to wrong.

so your support make openerp strong and flexible .

Thank you,
Sunil Jagyasi

Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 3 (openerp-dev-addons3)
importance: Undecided → Low
status: New → Confirmed
Changed in openobject-addons:
status: Confirmed → In Progress
Claire (cjin) wrote :

I have the similiar problem. The residual amount was fine before confirm the invoice. Once I validate the invoice, the residual amount = Net price + tax +tax again......

How could we fix it?

Hello Claire,

Solution:
We can use move_line_id_payment_gets method on Account invoice to filter move lines.

So if we call above method it just returns move lines which we have to pay (i mean only receivable/payable) from amount_residual.

Thanks,
mra

Changed in openobject-addons:
status: In Progress → Confirmed
jordg (gbj) wrote :

Hi,

I believe that the problem is in account_move_line.py._amount_residual
The method should overlook "Tax Payable" as that is already in the total. The problem is that it is adding the tax again.

So to fix I have changed the line from:
if not move_line.account_id.type in ('payable', 'receivable'):
to:
if not move_line.account_id.type in ('payable', 'receivable') or move_line.account_id.name in ('Tax Payable'):
Therefore the method is now overlooking the Tax.

This however may not work for some charts of accounts.
Can someone suggest a better fix. Maybe if we had a separate move_line.account_id.type such as tax_payable.

Thanks

Grahame Jordan

On the sales order tree view this problem is causing the invoiced % to show as a -ve value for the rate of tax. (in our case 15%)

Just noticed that this is an issue in multi-company sales order tree view but not in single company..go figure

Hello Kavin,

this is not an issue in multi-company, this problem arise when you change account in sale order line or invoice line,
do this :- select different account whose internal type except regular type, than you find that residual amount calculated = 2 * invoice amount.

so how you manage your account and how you handle your payment respect of that invoice.

i think this create very big problem if not to be fix.

thax

Hi all,

We have the same issue when we validate an invoice : residual amount = Net price + tax +tax again.

Instead of modifying the code, I checked our VAT accounts which were of type 'payable'. I change it to 'normal', like in the swiss localization we use and the problem was gone. I can create create correct invoices now.

I hope it is correct and it will help.

Andrek

Hello all,

With the reference to #8, i checked all the possibilities and found that it's happen due to wrong account configuration.

Only partner has receivable and payable accounts.

As you can see comment #8, they have solved the problem like this only.

Thanks,
Purnendu Singh

Cristian Salamea (ovnicraft) wrote :

@SJA Did you check if tax account type is not payable or receivable ?

Regards,

Changed in openobject-addons:
assignee: OpenERP R&D Addons Team 3 (openerp-dev-addons3) → nobody
importance: Low → Undecided
status: Confirmed → New
status: New → Invalid

Hello Purnendu Singh,

I think you are on wrong track, i am not talking about partner receivable and payable account i am talking about selection of account in order line, for your kind information we are not making invoice for sale and purchase of goods only, we can received invoice in respect of purchase of Building and other assets, so how you handle these type of situation.
In case if you select income account and expenses account that is wrong for you account (that is weakness of account).
and system never fixed for some particular prefix account, that must be flexible at all time.

Hello Vinay Rana,

Before changing the status invalid please make habit to check all the criteria.

Julián Lozano (jlozano) wrote :

Hello

I am using OpenERP 7 with Colombian localization packag and the issue still affect us. If the proper setting of internal account type for VAT account is payable or receivable, in this momento it can not be done so the taxes will be applied twice. So we select internal account to regular, but we did not know the effects of doing that for example in the reports section,etc.

Regards,

Marcelo (limamp) wrote :

Hi,

InBrazil the same error occurs. How can I fix it?

ahnne (ahnnegongora14) wrote :

 Hi got the same problem here.. how will i going to fix this?? please really need help

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions