[PATCH] Missing read permission on asterisk server object, needed for agi scripts

Bug #1174695 reported by Marcel van der Boom (HS-Development BV) on 2013-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenERP-Asterisk connector
Undecided
Unassigned

Bug Description

I found that the agi script get_cid* in effect needs read permission on the asterisk.server objects

Patch:

=== modified file 'asterisk_click2dial/security/asterisk_server_security.xml'
*** asterisk_click2dial/security/asterisk_server_security.xml 2013-01-01 10:34:45 +0000
--- asterisk_click2dial/security/asterisk_server_security.xml 2013-04-30 10:27:58 +0000
***************
*** 44,49 ****
--- 44,59 ----
      <field name="perm_unlink" eval="0"/>
      <field name="perm_create" eval="0"/>
  </record>
+ <!-- Read our server setttings -->
+ <record id="ir_model_access_asterisk_cid2" model="ir.model.access">
+ <field name="model_id" ref="asterisk_click2dial.model_asterisk_server"/>
+ <field name="name" eval="&quot;&quot;&quot;asterisk.server_read&quot;&quot;&quot;"/>
+ <field name="group_id" ref="asterisk_click2dial.group_asterisk_cid"/>
+ <field name="perm_read" eval="1"/>
+ <field name="perm_write" eval="0"/>
+ <field name="perm_unlink" eval="0"/>
+ <field name="perm_create" eval="0"/>
+ </record>

  </data>
  </openerp>

summary: - Missing read permission on asterisk server object, needed for agi
- scripts
+ [PATCH] Missing read permission on asterisk server object, needed for
+ agi scripts
Alexis de Lattre (alexis-via) wrote :

Thank you very much for your bug report and the patch. This problems was introduced recently by my commit revno 77. It is now fixed in revno 82 (trunk branch).

Changed in openerp-asterisk-connector:
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers