Asterisk Click2dial CRM - dialing bug with ubuntu precise

Bug #1084478 reported by Gianluca Gori @ LS on 2012-11-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenERP-Asterisk connector
Undecided
Unassigned

Bug Description

Hi,

We've installed the connector (both modules) and configured as per instructions.
We also added the "resource" field in the res.users.
When trying to call a partner we get this error:

Error :

Problem in the request from OpenERP to Asterisk. Here is the detail of the error: 'Server banner was incorrect.'

It looks like to be a problem with py-asterisk with ubuntu 12, however even applying the patch 0.1a3+r160-4.1 the problem is still present.

Is this a bug ? any solution to the problem?

Thanks!

Alexis de Lattre (alexis-via) wrote :

I think that your problem comes from the fact that you used python-asterisk as packages in Ubuntu 12.04 or 12.10.

As explained in the documentation of the OpenERP-Asterisk connector (cf http://www.akretion.com/open-source-contributions/openerp-asterisk-voip-connector), you should install py-asterisk from the mercurial of the project, in order to get a patch that I contributed very recently (no official release has been made since then) :

So remove the python-asterisk package and do :

% hg clone https://code.google.com/p/py-asterisk/
% cd py-asterisk
% sudo python ./setup.py install

Changed in openerp-asterisk-connector:
status: New → Incomplete

We ran into this as well on upgrading.

We had to apply this patch https://gist.github.com/mrvdb/7588470 to see the error. After that, the solution was pretty easy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers