Opencv haarcascades should not be shipped as documentation

Bug #698016 reported by Julien on 2011-01-06
116
This bug affects 26 people
Affects Status Importance Assigned to Milestone
OpenCV Manager
Undecided
Unassigned
opencv (Ubuntu)
Undecided
Unassigned

Bug Description

The haarcascades of opencv under ubuntu 10.10 are shipped in the opencv-doc package. They should be in /usr/share/opencv/haarcascades.

This affect digikam 2.0.0 beta 1 and some gnome apps, see here:
https://bugs.kde.org/show_bug.cgi?id=262074

Laura (stringarray) wrote :

This affects some GStreamer plugins, for example facedetect in gst-plugins-bad, about to be used in Cheese application.

In Lucid the files were installed: http://packages.ubuntu.com/lucid/i386/libcv-dev/filelist
In Maverick they aren't: http://packages.ubuntu.com/maverick/i386/libcv-dev/filelist

And they should be.

It would appear they're currently being distributed as part of the opencv-doc package and have been gzipped and moved to /usr/share/doc/opencv-doc/examples/haarcascades/haarcascades/

So you could potentially depend on that package and add support for gzipped cascades but that doesn't strike me as a terribly nice solution. Ideally they should be distributed in a non-gzipped form and installed to the most commonly used path (/usr/share/opencv/haarcascades).

 I'm not sure if libcv-dev is necessarily the best place to return these to though, since they have little to do with development and instead are runtime definitions for face/body detection, perhaps a separate opencv-haarcascades package?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in opencv (Ubuntu):
status: New → Confirmed

This renders face-recognizing not working.
Are anybody looking into repackaging?

Mattia Rizzolo (mapreri) wrote :

it's in opencv-data these days. closing.

Changed in opencv (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers