clean up attention allocation code to ensure output at different debug levels is consistent

Bug #250341 reported by ferrouswheel
2
Affects Status Importance Assigned to Milestone
OpenCog
Low
Unassigned

Bug Description

Make sure the output levels for each MindAgent are somewhat consistent. At the moment I suspect there is a lot more detail being output then needed at certain levels while I was experimenting with the Hopfield network emulator.

I also think that certain debug information should only be output if DEBUG is defined, since each log message still requires a function call regardless of whether the message is printed (although compiler optimisation might inline them I guess). Since attention allocation will be a frequent process it should be quick as we can make it.

all the agents in dynamics/attention should be checked.

ferrouswheel (joel-pitt)
Changed in opencog:
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
ferrouswheel (joel-pitt) wrote :

I've mostly completed this now. In staging branch.

Changed in opencog:
status: Confirmed → Fix Committed
linas (linasvepstas)
Changed in opencog:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints